Announcement Announcement Module
Collapse
No announcement yet.
How to uninstall/reinstall/update Spring Surf Roo Addon Page Title Module
Move Remove Collapse
X
Conversation Detail Module
Collapse
  • Filter
  • Time
  • Show
Clear All
new posts

  • How to uninstall/reinstall/update Spring Surf Roo Addon

    1) Download SpringSurf Roo addon zip from http://www.springsurf.org/downloads.html

    2) Startup Spring Roo.

    3) Run "addon list" to check if Surf Roo addon has been installed or not.

    4) Remove existing surf addon, run

    >> addon uninstall *surf*.zip

    3) Reinstall surf addon using the zip file you download

    >> addon install file:/[Path-to-your-zip-file]

  • #2
    Installing from Roo

    I am using 1.0.0.M2 - this worked:

    addon install --url http://www.springsurf.org/downloads/...-roo-addon.zip


    In your project at the roo prompt:

    roo> surf install


    Regards,
    Gordon Dickens
    twitter.com/gdickens
    Last edited by gdickens; Mar 28th, 2010, 02:42 PM.

    Comment


    • #3
      Yes. Spring has fixed that issue.

      I have updated the tutorial for that as well.

      Thanks!

      Yong

      Comment


      • #4
        STS3.3 with Google integration

        Hi,

        I have just downloaded this package :http://download.springsource.com/mil....5.2-win32.zip

        But none of the commands like "Install" or "addon" is available in ROO.

        I also tried to install the eclipse template for spring surf, no luck there either ? Is the new STS3.3 extendable for surf ?

        STS3.3 home contains the following :
        roo-1.1.0.M1 --- 1.1.0.M1 [rev 3a0b8a3]
        sts-2.3.3.M1
        maven-2.2.1.RELEASE
        tc-server-developer-2.0.0.SR01

        Comment


        • #5
          But none of the commands like "Install" or "addon" is available in ROO

          Did you get any answer on this??

          The documentation definitely says to run the addon command but that doesnt exist in Roo is it a new version or sthg. Have things changed?

          Comment


          • #6
            Hi davidhay,

            I posted 10 days ago but still no reply. I wish I knew who to contact directly But I join 2 weeks ago after seeing vmForce video about spring. And Since I do Alfresco aswell I thought it might be a good Idea to check out spring surf... but alas I failed miserable

            Comment


            • #7
              With the milestone release of Spring Roo 1.1.0.M1 (which is shipped with the milestone release of STS 2.3.3.M1) we have switched the addon infrastructure to use OSGi internally. This allows us to make the discovery, installation and management of addons by developers a whole new experience. Keep in mind that the milestone releases are not meant to be the final version of Roo 1.1, so some rough edges may be possible at times.

              The Roo 1.1.0.M2 release is just around the door and that will offer a much improved addon experience. Currently we use the 'osgi' commands to install and manage addons but this may be improved as we move towards a final release of Spring Roo 1.1.

              If you are looking to use the Surf addon I would recommend you use the latest GA release of Roo 1.0 and use the install commands as per documentation. It appears the surf addon is currently only compatible with Roo 1.0. I expect that the surf addon will be updated to work with the new addon infrastructure provided in Roo 1.1 once we reach the release candidate phase.

              I hope this answers your questions.

              Cheers,
              Stefan

              Comment


              • #8
                Is there an updated ETA on getting this addon working with the latest roo? Or maybe a work around? I've just installed STS 2.5.2, and have had issues getting 1.0 version of roo working with it.

                Thanks in advance
                gene

                Comment


                • #9
                  can you check out the trunk? The latest check in should let you build a Surf addon that works with Roo 1.1 (OSGI).

                  Comment


                  • #10
                    Thanks, I'll attempt that.

                    Comment


                    • #11
                      Not sure I'm doing this right.

                      gene$ mvn -v
                      Apache Maven 2.2.1 (r801777; 2009-08-06 14:16:01-0500)
                      Java version: 1.6.0_22
                      Java home: /System/Library/Java/JavaVirtualMachines/1.6.0.jdk/Contents/Home
                      Default locale: en_US, platform encoding: MacRoman
                      OS name: "mac os x" version: "10.6.6" arch: "x86_64" Family: "mac"

                      Checked out trunk, ran mvn install, and got successful build.

                      from inside STS2.5.2, roo shell, i run the following command:
                      osgi install --url file://path/to/spring-surf-roo-addon-1.0.0.CI-SNAPSHOT-roo-addon.zip

                      with the following result:
                      java.lang.NullPointerException

                      Comment


                      • #12
                        OK, getting closer.

                        Switched to Maven 3, checked out DEV_MAVEN3 everything builds until I get to spring-surf-roo-addon!

                        Looks like the culprit is org.springframework.roo.addon.backup-1.0.2.RELEASE.jar, cannot read

                        Code:
                        org.apache.maven.lifecycle.LifecycleExecutionException: Failed to execute goal org.apache.maven.plugins:maven-compiler-plugin:2.0.2:compile (default-compile) on project spring-surf-roo-addon: Compilation failure
                        error: error reading /Users/gene/.m2/repository/org/springframework/roo/org.springframework.roo.addon.backup/1.0.2.RELEASE/org.springframework.roo.addon.backup-1.0.2.RELEASE.jar; cannot read zip file
                        
                        	at org.apache.maven.lifecycle.internal.MojoExecutor.execute(MojoExecutor.java:213)
                        	at org.apache.maven.lifecycle.internal.MojoExecutor.execute(MojoExecutor.java:153)
                        	at org.apache.maven.lifecycle.internal.MojoExecutor.execute(MojoExecutor.java:145)
                        	at org.apache.maven.lifecycle.internal.LifecycleModuleBuilder.buildProject(LifecycleModuleBuilder.java:84)
                        	at org.apache.maven.lifecycle.internal.LifecycleModuleBuilder.buildProject(LifecycleModuleBuilder.java:59)
                        	at org.apache.maven.lifecycle.internal.LifecycleStarter.singleThreadedBuild(LifecycleStarter.java:183)
                        	at org.apache.maven.lifecycle.internal.LifecycleStarter.execute(LifecycleStarter.java:161)
                        	at org.apache.maven.DefaultMaven.doExecute(DefaultMaven.java:319)
                        	at org.apache.maven.DefaultMaven.execute(DefaultMaven.java:156)
                        	at org.apache.maven.cli.MavenCli.execute(MavenCli.java:534)
                        	at org.apache.maven.cli.MavenCli.doMain(MavenCli.java:196)
                        	at org.apache.maven.cli.MavenCli.main(MavenCli.java:141)
                        	at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
                        	at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
                        	at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
                        	at java.lang.reflect.Method.invoke(Method.java:597)
                        	at org.codehaus.plexus.classworlds.launcher.Launcher.launchEnhanced(Launcher.java:290)
                        	at org.codehaus.plexus.classworlds.launcher.Launcher.launch(Launcher.java:230)
                        	at org.codehaus.plexus.classworlds.launcher.Launcher.mainWithExitCode(Launcher.java:409)
                        	at org.codehaus.plexus.classworlds.launcher.Launcher.main(Launcher.java:352)
                        Caused by: org.apache.maven.plugin.CompilationFailureException: Compilation failure
                        error: error reading /Users/gene/.m2/repository/org/springframework/roo/org.springframework.roo.addon.backup/1.0.2.RELEASE/org.springframework.roo.addon.backup-1.0.2.RELEASE.jar; cannot read zip file
                        
                        	at org.apache.maven.plugin.AbstractCompilerMojo.execute(AbstractCompilerMojo.java:516)
                        	at org.apache.maven.plugin.CompilerMojo.execute(CompilerMojo.java:114)
                        	at org.apache.maven.plugin.DefaultBuildPluginManager.executeMojo(DefaultBuildPluginManager.java:107)
                        	at org.apache.maven.lifecycle.internal.MojoExecutor.execute(MojoExecutor.java:209)
                        	... 19 more
                        have deleted from my maven repo and rerun with same results. Any tips?

                        Thanks, gene

                        Comment


                        • #13
                          Upon further inspection, that is a 0byte sized file. See this url:

                          http://maven.alfresco.com/nexus/cont...1.0.2.RELEASE/

                          Can someone update that repo? or does it need to point somewhere else? This is a LOT of work just to get setup to do some work.

                          Comment


                          • #14
                            I found another copy of the 0 byte jar, replaced in my maven repo, and got a successful build for spring-surf-roo-addon project. However, I still get a java.lang.NullPointerException when I run the following command within roo:

                            Code:
                            osgi install --url file:/Users/gene/spring-surf-dev-m3/trunk/spring-surf-devtools/spring-surf-roo-addon/target/spring-surf-roo-addon-1.0.0.CI-SNAPSHOT-roo-addon.zip
                            I've tried from within STS, and also from command line (Roo 1.1.1.RELEASE).

                            Guess I'll start learning to create surf projects from hand, not sure what else to do.

                            Comment


                            • #15
                              Have the same issue.
                              It is really weird that nobody can provide any solution for that.

                              I have:
                              1. Roo version 1.1.2.RELEASE + Linux + ROO_HOME/bin in path and soft link created.
                              2. Tried as suggested addon install --url http://...
                              -> Failed because there is no any --url option for addon install
                              3. Download addon manually and tried install through out osgi
                              roo> osgi start file:/home/user/....zip
                              -> failed because it is not osgi bundle
                              Then extract from archive spring-surf-roo-addon-1.0.0-RC2.jar and do the same for it
                              roo> osgi start file://local/path/to/spring-surf-roo-addon-1.0.0-RC2.jar

                              Bundle successfully installed and active.
                              I.e.
                              roo> osgi ps
                              ...
                              [ 67] [Active ] [ 1] file:/home/me/Java/springsource/spring-surf-roo-addon-1.0.0-RC2.jar

                              But!

                              roo> help surf install

                              ** Type 'hint' (without the quotes) and hit ENTER for step-by-step guidance **

                              roo> surf install

                              roo> surf install
                              Command 'surf install' not found (for assistance press TAB or type "hint" then hit ENTER)
                              addon search --requiresCommand "surf install" found no matches

                              So, this is just installed as OSGi bundle but not Roo addon.

                              Is anybody has a clue how to use this advertised support for Spring Roo + Spring Surf?

                              Any ideas please...

                              Comment

                              Working...
                              X