Announcement Announcement Module
Collapse
No announcement yet.
Support for Python 2.6 Page Title Module
Move Remove Collapse
X
Conversation Detail Module
Collapse
  • Filter
  • Time
  • Show
Clear All
new posts

  • Support for Python 2.6

    Hi,
    I am currently using Python 2.6. I've downloaded the latest version of SpringPython, Amara 1.2, and 4Suite XML 1.0.2. However, after installing 4Suite XML, I noticed that it does not work with Python 2.6. I have to revert back to Python 2.5 in order for everything to work. Is it possible to use SpringPython with Python 2.6+ or 3.0+? What version of 4Suite XML should I use? If not, is there any plan to support those versions of Python in the near future? Thanks.

  • #2
    There are currently plans to have 1.0.0.GA support python 2.6 (as well as 2.4 and 2.5). Yesterday, I was coding the last bits to support that.

    We should have a release soon with those changes. However, if you want to get a jump on the changes, there's always the source code:

    Comment


    • #3
      Thanks!!

      Greg... thanks.
      So with this release (1.0.0GA), do I still need to wait for 4Suite or Amara to come out with something that would support Python 2.6? Anyway, I will just wait for the release. Thanks again.

      Comment


      • #4
        I don't think so. I installed amara package into python2.6 (without directly installing 4Suite), and it works fine.

        Comment


        • #5
          Also, I have started capturing info on configuring your machine to development Spring Python. See http://wiki.springpython.webfactiona...ld_environment

          Comment

          Working...
          X