Announcement Announcement Module
Collapse
No announcement yet.
Build problems SAS 1.2-SNAPSHOT Page Title Module
Move Remove Collapse
X
Conversation Detail Module
Collapse
  • Filter
  • Time
  • Show
Clear All
new posts

  • Build problems SAS 1.2-SNAPSHOT

    Hi List,

    today I tried to build the SAS trunk from scratch.

    My box uses: Win 7, Java 1.6.20, Maven 2.2.1.

    Unfortunately I got an error, the event-bus component says it can't find the WeakLinkedList object.

    Then I was able to compile as3commons from scratch using Maven 3, I adjusted the dependencies in SAS and tried to build SAS again.
    Now IWeakLinkedList is not found.

    Originally I just wanted to debug SAS because some declared objects are not found in my context-inheritance using
    Code:
    ModuleLoader.applicationdomain=new ApplicationDomain(ApplicationDomain.currentDomain)
    Unfortunately the latest Snapshot in the Maven Repository doesn't match the trunk, so I can't debug properly.

    Can you please fix this so the SVN trunk matches the version provided in the Maven Snapshots repository?

    Thank you in advance,
    Christoph

  • #2
    Hi List,

    today I tried again to build springactionscript-core and after changing some settings in the main pom.xml I was able to build the core (even with skipping the tests).
    You can find my modified pom here.You can find my modified pom here.

    Maybe it is an good idea to put the SpringActionscript and the as3commons project into a Continuous Integration system so nightly builds from the current SVN trunk are available.

    Now I'm really looking forward to investigating my original problem.

    Regards,
    Christoph
    Last edited by flex-guse; Mar 20th, 2011, 09:30 AM.

    Comment


    • #3
      Hey Christoph,

      thanks a lot for your continued efforts, I'll have a look at your changes a.s.a.p. and perhaps merge them with our pom in SVN. Thanks!!

      As for the CI server, its still part of the planning, as far as I know SpringSource does have a Bamboo server that we can use, we just need to find a spot of time to actually get it up and running.

      As3commons is being hosted at google so there's no option for a CI server there, we'd have to set up something for ourselves I suppose.

      Anyways, food for thought...

      cheers,

      Roland

      Comment


      • #4
        Unfortunately the download link doesn't work for me, I'm getting a 'no files available' page...

        Cheers,

        Roland

        Comment


        • #5
          Hi Roland,

          it seems the my hosting platform (Origo in Switzerland) is currently not available or very slow. Maybe this is fixed in a couple of hours.

          If the FlexSDK should not be updated from 3.5 to 4.1 I think only the exclusion in the as3commons-lang is necessary (this included the Flex SDK 3.2 and flexmojos claimed the used flex-compiler 3.5 and the framework does not fit).

          Code:
                  <dependency>
                      <groupId>org.as3commons</groupId>
                      <artifactId>as3commons-lang</artifactId>
                      <version>${as3commons-lang.version}</version>
                      <type>swc</type>
                      <scope>external</scope>
                      <exclusions>
                          <exclusion>
                              <groupId>com.adobe.flex.framework</groupId>
                              <artifactId>flex-framework</artifactId>
                          </exclusion>
                      </exclusions>
                  </dependency>


          Currently I only have been working with the CI server Hudson. Hudson is available to check out any SVN sources and build them. Maybe thats also possible with Bamboo, so that it is no problem to host the sources in an SVN outside the Spring universe.

          Have a nice weekend,
          Christoph

          Comment


          • #6
            Originally posted by 666shooter View Post
            Unfortunately the download link doesn't work for me, I'm getting a 'no files available' page...

            Cheers,

            Roland
            Origo is up again, the POM should be available again.

            Cheers,
            Christoph

            Comment


            • #7
              thanks!

              Hey Christoph,

              I've commited your changes to SVN, thanks a lot for your contribution!

              I'll have a look at those failing tests as.a.p.

              cheers,

              Roland

              Comment

              Working...
              X