Announcement Announcement Module
Collapse
No announcement yet.
help with application context and objects Page Title Module
Move Remove Collapse
X
Conversation Detail Module
Collapse
  • Filter
  • Time
  • Show
Clear All
new posts

  • help with application context and objects

    i'm trying to get springactionscript framework working. right away i'm having a weird issue with the applicationcontext.xml. i started with the example right from the documentation, chapter2.

    my applicationcontext.xml file looks like this:

    <?xml version="1.0" encoding="utf-8"?>
    <objects xmlns="http://www.springactionscript.org/schema/objects"
    xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"
    xsi:schemaLocation="http://www.springactionscript.org/schema/objects
    http://www.springactionscript.org/schema/objects/spring-actionscript-objects-1.0.xsd">


    <object id="remoteObject" class="mx.rpc.remoting.mxml.RemoteObject" abstract="true">
    <property name="endpoint" value="http://localhost:8080/FlexWeb/messagebroker/amf" />
    <property name="showBusyCursor" value="true" />
    </object>

    <object id="roLocaleService" parent="remoteObject">
    <property name="destination" ref="localeService"/>
    </object>
    <object id="roTenantService" parent="remoteObject">
    <property name="destination" ref="tenantService"/>
    </object>

    </objects>


    and the error i get when the app tries to start up is:

    Caused by: org.springframework.beans.factory.parsing.BeanDefi nitionParsingException: Configuration problem: Unable to locate Spring NamespaceHandler for XML schema namespace [http://www.springactionscript.org/schema/objects]

    clearly, i've got the correct url. but i can't figure out why it won't load properly.

  • #2
    Hi,

    given the exception, it seems like you are trying to parse a Spring ActionScript XML configuration file with the Spring (Java) framework.

    Are you mixing up the 2 projects?

    regards,
    Christophe

    Comment


    • #3
      yes, the problem was the property tag in the object tags.
      this does not work:

      <object id="roLocaleService" parent="remoteObject">
      <property name="destination" ref="localeService"/>
      </object>

      but this does work:

      <object id="roLocaleService" parent="remoteObject">
      <property name="destination" value="localeService"/>
      </object>

      Comment

      Working...
      X