Announcement Announcement Module
Collapse
No announcement yet.
SA with flexunit4 can't open server socket for test. Page Title Module
Move Remove Collapse
X
Conversation Detail Module
Collapse
  • Filter
  • Time
  • Show
Clear All
new posts

  • SA with flexunit4 can't open server socket for test.

    In the past, when I apply some code that use spring-actionscript, which can integrate with flexunit4UIRunner as well (use Flex UI for present test status). The testsuite can use spring-actionscript to help the DI process of the test and the testsuite was run correctly. But in that application, there are some issues that I noticed for sometime ago.

    When I run Ant script to run testsuite that use spring-script to make DI, console told me something strange. It wait for client connection to server and it wait until timeout so the client can't connect to server. But the testsuite code was execute correctly. This issue doesn't bother me for that time, because I can run test and use DI framework for test code that's all. It's not important that client can't connected to server because it doesn't matter to me.

    When I use the lastest nightly build of flexUnit4Test Project. I have test with flexcover and Hudson and the result is good, I can integrate with flexunit, flexcover, Hudson together. This test used FlexCoverListener, which not use UI for monitor test status but use only CI for monitor.

    But the situation is different when I work with CI tools (Hudson). When I commit code to repository server and CI was notified that the repository's code was changed.The CI was run ant script as in normal time. Everytime before Ant script run testsuite, It have to connect to server and client will wait for connection status, if the waiting time was timeout it say that the test fail and the testsuite was not executed at all.

    So, when I use manual-style Dependency Injection (injected dependency object by manual) the testsuite work well as normal. But when I use spring-actionscript the same issue in the past was occured, which the testsuite app. client can't connected to server so the testsuite was not executed.

    I don't know what is the source of problem because I use the lastest version of spring-actionscipt (0.8.1) but the save issue was alway occured, doesn't it is a bug.

    Please help me so that I can use this beautiful framework in my recent project.
    Last edited by him_aeng; Oct 19th, 2009, 05:05 AM.

  • #2
    Please tell me that, how can I solve this issue?

    Comment


    • #3
      Hi,

      are you sure the application context xml files are found by Hudson? It seems like a timeout is occurring because of an IO Error or so. Other than that, I can't imagine that this is a Spring ActionScript issue.

      regards,
      Christophe

      Comment

      Working...
      X