Announcement Announcement Module
Collapse
No announcement yet.
sas namespace issue Page Title Module
Move Remove Collapse
X
Conversation Detail Module
Collapse
  • Filter
  • Time
  • Show
Clear All
new posts

  • sas namespace issue

    Hello,

    I am trying to use the MXML implementation.

    If I put the namespace xmlns:sas="http://www.springactionscript.org/mxml/config" it doesn't recognize it.

    This one works :
    xmlns:sas="org.springextensions.actionscript.conte xt.support.mxml.*"

    I added all libraries (using Flex 4).

    Is there something I can do or it is not ready yet ?

    Thank you in advance.

  • #2
    is an error in the distributed build

    Hi there,

    I also just noticed this, I think its an error in the Maven build that prepares the distributions where the manifest isn't included properly.
    Right now adding the components with the explicit package name is indeed the only way to get it working:
    xmlns:sas="org.springextensions.actionscript.conte xt.support.mxml.*"

    I'll hope we'll get the manifest business sorted for the next release, please bear with us

    cheers,

    Roland
    Last edited by 666shooter; Sep 12th, 2009, 03:57 AM. Reason: fixed typo...

    Comment


    • #3
      fixed

      FYI, this issue has been resolved in version 0.8.1 that was just released.
      Downloads can be found here:
      http://www.springactionscript.org/

      or you can always check out the trunk and create your own build.

      cheers,

      Roland

      Comment


      • #4
        I still seem to be suffering the same issue.

        I am using spring as 0.8.1 and flex 4 beta.

        I have tried both the workaround suggest here and the method described in the documentation.

        Flex builder does not auto complete the mxmlapplicationcontext tag but when using open type it sees the class.

        http://bbox.homelinux.net:8080/~blac...2019.08.23.png
        http://bbox.homelinux.net:8080/~blac...2019.08.33.png
        http://bbox.homelinux.net:8080/~blac...2019.07.48.png

        Any help will be greatly appreciated, I will need auto-wiring for stage components.

        Comment


        • #5
          weird...

          It seems there's still something wrong with the build scripts apparently, for now I suggest you use the explicit namespace like this:

          xmlns:sas="org.springextensions.actionscript.conte xt.support.mxml.*

          that ought to work...

          cheers,

          Roland

          Comment


          • #6
            I tried that, but it also did not work.

            I noticed there was a space in the word context ... removed it, did not work.

            So maybe it's not even related to the namespace issues, since I am completely unable to even auto-complete the class MXMLApplicationContext?

            Comment


            • #7
              weirder still...

              hey there, yea, sorry about that space in the namespace

              if even the explicit namespace doesn't work there must be something more fundamentally wrong in your project. How did you add the spring actionscript .swc to yuor project?

              cheers,

              Roland

              Comment


              • #8
                Sorry, for the delay in posting, my problem still hasn't been solved.

                This is how I include the spring-as swc, I use maven to resolve my dependencies.

                http://bbox.homelinux.net:8080/~blac...2022.30.08.png

                Comment


                • #9
                  Confirmed that this issue still exists for both 0.8.1 and 0.9-SNAPSHOT releases.

                  It does work for me if I explicitly import the package namespace like this:

                  Code:
                  xmlns:mxml="org.springextensions.actionscript.context.support.mxml.*"

                  Comment


                  • #10
                    Hi all,

                    it seems to me that this is an issue with FlexMojos. Although I can get this to work with FlexBuilder, FlexMojos does not seem to generate the needed info in the catalog.xml file of the library.

                    I have posted a message on their group here: http://groups.google.com/group/flex-...e85aa6b674e463

                    For now, and as stated earlier, I would propose to just reference the package in the namespace.

                    regards,
                    Christophe

                    Comment

                    Working...
                    X