Announcement Announcement Module
Collapse
No announcement yet.
Autowiring abstract objects Page Title Module
Move Remove Collapse
X
Conversation Detail Module
Collapse
  • Filter
  • Time
  • Show
Clear All
new posts

  • Autowiring abstract objects

    I am having an issue trying to autowire two objects that share an abstract parent. I can autowire successfully if there is only one child object. As soon as I add the second object autowiring doesn't seem to work. I've tried setting it to autowire byName, but no luck there either. Here is the context I am using.

    Code:
    <?xml version="1.0" encoding="utf-8"?>
    <objects>
     
    	<object id="remoteObject" class="mx.rpc.remoting.mxml.RemoteObject"	abstract="true" autowire="byName">
    		<property name="endpoint" value="http://localhost:8080/links/messagebroker/amf" />
    		<property name="showBusyCursor" value="true" />
    	</object>
     
    	<object id="promoService" parent="remoteObject" autowire="byName">
    		<property name="destination" value="promoService" />
    	</object>
    	
    	<object id="keywordService" parent="remoteObject" autowire="byName">
    		<property name="destination" value="keywordService"/>
    	</object>
     
    </objects>

  • #2
    bug

    Hi there,

    at first glance I'd say this is a bug, since I don't really see anything wrong with your context here. Please file a bugreport for the issue in our bugtracker, that way it'll get picked up a.s.a.p.:

    http://jira.springframework.org/brow...ACTIONSCRIPTAS

    thanks,

    Roland

    Comment

    Working...
    X