Announcement Announcement Module
Collapse
No announcement yet.
errors when running mvn clean test on SAS 2.0 Page Title Module
Move Remove Collapse
X
Conversation Detail Module
Collapse
  • Filter
  • Time
  • Show
Clear All
new posts

  • errors when running mvn clean test on SAS 2.0

    Hi guys,

    I'm using SAS 2.0 for a framework that I'm building. I discovered some issues when trying to run mvn clean test on the latest trunk.

    First, in FieldRetrievingFactoryObjectTest.as there's an import of spark.components.Application that needs to be removed.

    Second, the TestRunner has skin dependencies that need to be added to avoid errors like the following:

    _TestRunner_Styles.as(1224): col: 50 Error: Access of undefined property BorderSkin.

    I got past that by adding the following:

    <dependency>
    <groupId>com.adobe.flex.framework</groupId>
    <artifactId>spark</artifactId>
    <version>${flex-sdk.version}</version>
    <type>swc</type>
    <scope>test</scope>
    </dependency>
    <dependency>
    <groupId>com.adobe.flex.framework</groupId>
    <artifactId>sparkskins</artifactId>
    <version>${flex-sdk.version}</version>
    <type>swc</type>
    <scope>test</scope>
    </dependency>

    Now that I'm past that, FlexMojos can't find FlashPlayer. We use an older version of FM that doesn't have that problem, so my next challenge is to figure out what has changed. Hopefully that's the last issue!

    Cheers,

    Tom

  • #2
    Path

    Hey Tom,

    thanks for the pom fix, I've added them to the parent pom and removed the unneccesary import in the FieldRetrievingFactoryObjectTest.

    As for the flashplayer/adl.exe that isn't found, I have added the path to the flash player and adl.exe to my PATH environment variable, so for a Flashbuilder 4.6 install this would be:

    <FlashBuilderInstallDirectory>\Adobe\Adobe Flash Builder 4.6\player\win\11.1

    <FlashBuilderInstallDirectory>\Adobe\Adobe Flash Builder 4.6\sdks\4.6.0\bin\

    Hope that helps...

    (oh, and yes, a bunch of tests are failing right now, I'm in the middle of refactoring a lot of stuff)

    cheers,

    Roland

    Comment

    Working...
    X