Announcement Announcement Module
Collapse
No announcement yet.
Problem with Valkyrie Simple Sample Page Title Module
Move Remove Collapse
X
Conversation Detail Module
Collapse
  • Filter
  • Time
  • Show
Clear All
new posts

  • #16
    Quite strange that it doesn't use the aspectjtools from your maven plugin (otherwise it would've used 1.6.7. I'm currently used 10.0.2 with JDK 1.6.0_20 on Ubuntu with Maven 3.0. Unfortunately, I don't have a Mac to test this on. I'll have a look.

    Comment


    • #17
      I had to put the compiler path manually otherwise it does not work. Maybe there is the problem. How I can make it take the maven pluging?

      Comment


      • #18
        I found one detail, in the archetype the aspectj pluging it's not configured. I put it manually and now the IDEA work with the maven pluging but ... still having the same NPE.

        Comment


        • #19
          I just pushed the change so that every Valkyrie subproject uses the aspectj plugin. This way STS now works too. I also upgraded the aspectj plugin to 1.3.1, which uses aspectrt 1.6.10.

          Comment


          • #20
            And ... the magic was done . Now it's working. Look like with the las changes you made it work great.

            Now I will make the real test with MyDoggy.

            Thanks a lot for the help

            Comment


            • #21
              You're welcome

              Comment


              • #22
                Interesting one thread... got knowledge and having solution of problems...

                Comment


                • #23
                  Is there a way to make this run in Eclipse? I don't want to use IntelliJ or STS, but I'm definitely interested in Vaklyrie.

                  Comment


                  • #24
                    Got this to build in IntelliJ, but had trouble running the samples. I had sometime this weekend that I spent working on it.

                    Is Valkyrie still active?

                    thanks,

                    John

                    Comment


                    • #25
                      Valkyrie Samples don't work

                      Same here. I was able to get the samples to compile, but I kept getting at stacktrace after attempting to log in using the simple example.

                      Is Valkyrie being worked on?

                      Anyone?

                      Comment


                      • #26
                        It most certainly is, but due to time constraints I haven't been able to do much in the last couple of weeks. Normally, this should change in the next couple of weeks . Could you tell me what the problems are?

                        Comment


                        • #27
                          Issues w/ Valkyrie

                          Hi LievenDoclo.

                          I wish I had kept the stacktrace. If you do a clean checkout from the trunk, and attempt to build the entire project, you will get some build errors. I used Maven 3.
                          You can comment out the offending modules, and get around that. However, once I got it built, I tried launching the Simple example via the maven exec command (mvn exec).

                          I got the login dialog, and I tried logging in as admin/admin, but I got a NPE.
                          I also tried running the other examples (showcase, etc) to no avail.

                          I suspect you may have had some different jars in your local repo that obscured the build error that one gets w/ the clean checkout and an initially empty repo.

                          Thank you for putting in the time on this new project. There are several people I know outside of my current company who are also trying to get Valkyrie up and running for the Spring 3 capabilities, so I know this is a useful project for people.

                          Comment


                          • #28
                            FYI, the Valkyrie trunk doesn't build w/o hacking the POMs quite a bit. There are a lot of artifacts that aren't in the repositories defined in the POM. This causes major headaches for anyone wanting to check it out.

                            Comment


                            • #29
                              I found out today that you *need* to be using aspectjrt 1.6.10 - spring-jpa-data was bringing in 1.6.8

                              Comment


                              • #30
                                I bookmarked this guestbook. Thank you for good job! Here is the link for my site Cyber Design please take a look at it

                                Comment

                                Working...
                                X