Announcement Announcement Module
Collapse
No announcement yet.
Updating from 1.0.0 to 1.1.0 Page Title Module
Move Remove Collapse
X
Conversation Detail Module
Collapse
  • Filter
  • Time
  • Show
Clear All
new posts

  • Updating from 1.0.0 to 1.1.0

    Hi,

    today I tried to update timefinder to use spring rc 1.1.0 and I only had some minor refactoring issues, which where quickly solved.
    BTW: All people trying this should be aware of
    [RCP-575] - Merge modules core, binding, forms, support and jdk5 into core

    Another issue was
    http://jira.springframework.org/browse/SPR-4524
    where I got an exception on context loading.

    I solved this at the moment with upgrading from spring 2.5.5 to 2.5.6:
    Code:
       <dependency>
                <groupId>org.springframework</groupId>
                <artifactId>spring</artifactId>
                <version>2.5.6</version>
        </dependency>
    
        <dependency>
                <groupId>org.springframework.richclient</groupId>
                <artifactId>spring-richclient-core</artifactId>
                <version>${springrc.version}</version>
                <exclusions>
                    <exclusion>
                        <groupId>org.springframework</groupId>
                        <artifactId>spring</artifactId>                    
                    </exclusion>
                </exclusions>
            </dependency>
    Would it be possible to update spring rc to the latest spring?

  • #2
    Hmmh, and there seems to be a dependency to swingx although I am using nacho:
    Code:
    Reason java.lang.NoClassDefFoundError: org/jdesktop/swingx/JXDatePicker
             org.springframework.richclient.form.builder.support.ColorValidationInterceptorFactory$ColorValidationInterceptor.getInnerComponent(ColorValidationInterceptorFactory.java:96)
             org.springframework.richclient.form.builder.support.ColorValidationInterceptorFactory$ColorValidationInterceptor.processComponent(ColorValidationInterceptorFactory.java:86)
             org.springframework.richclient.form.builder.support.ChainedInterceptorFactory$ChainedInterceptor.processComponent(ChainedInterceptorFactory.java:82)
             org.springframework.richclient.form.binding.support.AbstractBindingFactory.interceptBinding(AbstractBindingFactory.java:92)
             org.springframework.richclient.form.binding.support.AbstractBindingFactory.createBinding(AbstractBindingFactory.java:70)
             org.springframework.richclient.form.binding.support.AbstractBindingFactory.createBinding(AbstractBindingFactory.java:55)
             org.springframework.richclient.form.builder.AbstractFormBuilder.createDefaultBinding(AbstractFormBuilder.java:127)
             org.springframework.richclient.form.builder.TableFormBuilder.add(TableFormBuilder.java:109)
             org.springframework.richclient.form.builder.TableFormBuilder.add(TableFormBuilder.java:85)
             de.timefinder.core.ui.form.LocationForm.createFormControl(LocationForm.java:41)
    I had to include it in the pom:
    Code:
            <dependency>
                <groupId>org.swinglabs</groupId>
                <artifactId>swingx</artifactId>
                <version>0.9.5-2</version>
            </dependency>
    The latest version 0.9.7 is not yet in the public repository:
    http://repo2.maven.org/maven2/org/swinglabs/swingx/

    Comment

    Working...
    X