Announcement Announcement Module
Collapse
No announcement yet.
rcp -> spring version requirements? Page Title Module
Move Remove Collapse
X
Conversation Detail Module
Collapse
  • Filter
  • Time
  • Show
Clear All
new posts

  • rcp -> spring version requirements?

    I have checked out both the spring and spring-rcp HEAD into eclipse projects in the same workspace. There seem to be changes in spring that are not reflected in spring-rcp ('org.springframework.enum' is not 'org.springframework.enums').

    Should I be using a specific version spring when working with spring-rcp HEAD?

  • #2
    Barry,

    I can't find any reference to org.springframework.enum (this package name changed some time ago) are you sure you've checked out spring-rcp HEAD? If so can you show me where this reference is?

    Also to work with spring-rcp you don't need to have Spring checked out as rcp comes with snapshots of the spring jars however, in general, spring-rcp HEAD should be compatible with spring HEAD.

    Ollie

    Comment


    • #3
      Actaully, I have a whole bunch of errors, that one was just an example. The enum package is reference by org.springframework.rcp.factory.DefaultComponentFa ctory (v1.31).

      But I don't seem to have any spring snapshot jars in the cvs checkout. The lib directory has concurrent thru jgoodies-look, but no spring jars. Also, the elcipse project had a dependency on the spring eclipse project (which is where all of spring classes are being imported from).

      I checked out the spring-rcp module HEAD from cvs.sourceforge.net:/cvsroot/springframework/spring-rcp. Obviously I've got something mixed, but I can't see what.

      Comment


      • #4
        OK I see the problem.

        Rich client moved to a seperate project a while back you should by doing the checkout from:

        cvs.sourceforge.net:/cvsroot/spring-rich-c

        The project home is:

        http://sourceforge.net/projects/spring-rich-c/

        Do you happen to remeber where you found the link you used?

        Ollie

        Comment


        • #5
          Thanks!

          I get the location via springframework.org -> Sub Projects:Rich Client Project -> Downloads, which then takes me to the springframework sourceforge. So I just pulled the module spring-rcp from there.

          Probably need to get SF to kill the above module.

          Comment


          • #6
            Yes, we will have SF kill it. Thanks!

            Comment

            Working...
            X