Announcement Announcement Module
No announcement yet.
Problems setting up RCP 4 development Page Title Module
Move Remove Collapse
Conversation Detail Module
  • Filter
  • Time
  • Show
Clear All
new posts

  • Problems setting up RCP 4 development

    Hey guys,

    I'm just curious as to whether the instructions on the page:

    are accurate and up to date.

    I tried setting up the project and I ran all mvn install and mvn eclipse:eclipse commands but it doesn't seem to give me a proper set of source code.

    I still have things like "package $package" at the head of java files. And there just seems to be a whole lot of source files missing.

    Is there anything i should know about that i'm missing when it comes to setting up RCP for development?

    Johnny A

  • #2

    The problem with "package $package" and similar things most probably come from spring-richclient-archetype project under Eclipse. It is actually not a problem at all. The folder /src/main/resources contains Java code templates that are not meant to be syntax-validated as Java source, but Eclipse does exact that :-)

    If this is bothering you, just close the archetype project. It would be nice if Eclipse had a way to specify that certain source folders contains unparseable resources to be copied to output directory.

    Hope this clears things a bit,



    • #3
      I am not an eclipse user (intellij addict). A patch for the developerSetup.apt which adds a sentence to clear this problem up is very welcome


      • #4

        Thanks for the reply. Yep you're right about the archetype project. But I don't think any of the projects are right since i don't have any of the expected java files...

        I haven't given up yet i'm gonna try the whole process one more time. (This will be the third time). Crossing my fingers.



        • #5
          Actually I just had a look at the online repository:

          and i can't seem to find any of the core java source files there. What's up with that? If i am mistaken can some actually point me to an instance of the java sources for RCP core??

          UPDATE: I just did a fresh checkout from subversion and it looks like most java files are missing. The core/src/main/java dir is empty as are most others.
          I used the svn checkout command listed on the RCP website:

          svn checkout spring-richclient

          Last edited by johnny; Jul 19th, 2006, 06:55 AM.


          • #6
            core/src/main/java is empty because everything is still in support/src/main/java and needs to be divided up into the modules.


            • #7
              Thanks Geoff,

              I was under the impression that everything was already divided into modules. Anyways thanks for the clarification. A bit more info on the website would be nice though.