Announcement Announcement Module
Collapse
No announcement yet.
Which Java version are you using? Should we limit ourselves to 1.5? Page Title Module
Move Remove Collapse
X
Conversation Detail Module
Collapse
  • Filter
  • Time
  • Show
Clear All
new posts

  • Which Java version are you using? Should we limit ourselves to 1.5?

    Many of us on the developer list would like to take use of tiger (java 1.5) features outside the tiger module.
    We did a poll there and only one person is still using java 1.4, but he might move to 1.5 in the future.

    Which java version are you using?

  • #2
    Still using 1.4. In my opinion it is too early to set 1.5 as baseline now.

    Regards,
    Andreas

    Comment


    • #3
      PS: If you 're still using 1.4, could you post a estimated date when you will migrate up?

      Comment


      • #4
        Well, I have no current project using RCP right now. It's just, that most projects I am involved in (or recently have been) still use 1.4.
        I just think that there might be a problem if RCP might become an issue on a project based on 1.4.
        Thus, my objection is just a more general one and not specific.

        Regards,
        Andreas

        Comment


        • #5
          I am just a junior member, but IMO, the RCP should use all the good things from Java 1.5. It's not a new thing. We can even get Java 6 beta. So, why stay with 1.4?

          Thanks!

          Charles

          Comment


          • #6
            IMO a framework or library like spring rcp should have low requirements to its environment as possible. I really like the features of 1.5. But if spring rcp will only run on 1.5 it will limit the users and this is not the intention of spring. It would be great if we can find a way writing 1.5 code but still be able to create 1.4 or 1.3 binaries.

            Did anyone had a look at http://retroweaver.sourceforge.net ?

            Comment


            • #7
              I don't know if this discussion is still alive.
              I really would like to see Spring RCP move to Java 5. This is a major step forward and beeing able to use Generics is one of my biggest dreams .

              Of course I suggest do provide 1.4 jars.
              http://retrotranslator.sourceforge.net/ is a great tool that we use at our company with great success. Of course not every single feature of 1.5 can be "retrotranslated". But all "important" features work really great. It is very easy to integrate retrotranslator within the build process. So I see no reason to stay on 1.4...

              Comment

              Working...
              X