Announcement Announcement Module
Collapse
No announcement yet.
SimpleJaxWsServiceExporter and RuntimeModelerException - am I missing something? Page Title Module
Move Remove Collapse
X
Conversation Detail Module
Collapse
  • Filter
  • Time
  • Show
Clear All
new posts

  • SimpleJaxWsServiceExporter and RuntimeModelerException - am I missing something?

    Hello all,

    having read section 17.5.6 in the Spring reference manual one would think that publishing a bean as a simple standalone SOAP service would be easy. However, I'm obviously missing something as this is the error I get:

    Code:
    com.sun.xml.internal.ws.model.RuntimeModelerException: runtime modeler error: Wrapper class my.wsclass.jaxws.RegisterGateway is not found. Have you run APT to generate them?
    Now, I am actually running under JDK 1.6 (1.6.0_06-b02 to be precise), and there is nothing strange in the context definition either:

    Code:
    <bean class="org.springframework.remoting.jaxws.SimpleJaxWsServiceExporter">
        <property name="baseAddress" value="localhost:4444/"/>
      </bean>
      <bean id="ws" class="my.wsbackingclass"
      	init-method="init"/>
      <bean id="wsep" class="my.wsclass">
      	<property name="ws" ref="ws"/>
      </bean>
    The baseAddress in the code above is actually prefixed with the correct http prefix, I had to take it out because the forum is refusing to allow me post "URLs to other sites". And not to forget, I tried with SimpleHttpServerJaxWsServiceExporter and I got the exact same error.

    Small print: could this problem be connected to the fact that this context is run in an OSGi container under spring-dm? Is spring-dm somehow responsible for not executing the bindings for this webservice to initialize? And if so, what would be the simplest way to implement a SOAP ws in an OSGi bundle?
    BTW, before running into this error, I got a strange "class not found" from the OSGi container complaining it can't find
    org.springframework.orm.jpa.support.PersistenceAnn otationBeanPostProcessor
    which I solved by importing that package into the bundle. However, since I'm using annotations only in the webservice class and not using any ORM classes, I wonder why this error surfaced?

    Thanks in advance!

  • #2
    Hi canobi,

    Did you get this issue solved already? I'm having the same problem but using plain spring container.

    Regards,

    Roger

    Comment


    • #3
      Originally posted by rogerweb View Post
      Hi canobi,
      Did you get this issue solved already? I'm having the same problem but using plain spring container.
      Well actually, I found here in the forums that using this
      annotation on the SOAP client class or interface: @SOAPBinding(parameterStyle=ParameterStyle.BARE)
      helps and indeed that makes the error go away. I haven't tried using the class after adding it though, but I think it should work, otherwise I'll be back here with a followup question :-)

      Comment

      Working...
      X