Greetings All,
This one came up out of the blue today. Haven't had a need to run my junit tests in about a month. today, i ran them, and I get this error:

Caused by: org.springframework.beans.factory.BeanCreationExce ption: Error creating bean with name 'serviceExporter' defined in class path resource [com/argus/pola/application/props/applicationContext.xml]: Invocation of init method failed; nested exception is java.rmi.ServerException: RemoteException occurred in server thread; nested exception is:
java.rmi.UnmarshalException: error unmarshalling arguments; nested exception is:
java.lang.ClassNotFoundException: null (no security manager: RMI class loader disabled)

I can think of nothing at all that's changed in the system to warrant this message.

here's my export in applicationContext.xml:

<bean id="serviceExporter" class="org.springframework.remoting.rmi.RmiService Exporter">
<property name="service">
<ref local="polarunner"/>
</property>
<property name="serviceInterface">
<value>blah.OptimizerRunner</value>
</property>
<property name="serviceName">
<value>POLARunner</value>
</property>
</bean>


I've not needed a policy file before. so i put one together with all permissions granted, then called System.setProperty("java.security.policy","rmi.pol icy") before the call to new ClassPathXMLApplicationContext(blah.xml)....

still the same thing.

Any advice?