Announcement Announcement Module
Collapse
No announcement yet.
HttpInvoker incompatible with Servlet 2.3? Page Title Module
Move Remove Collapse
X
Conversation Detail Module
Collapse
  • Filter
  • Time
  • Show
Clear All
new posts

  • HttpInvoker incompatible with Servlet 2.3?

    Hi,
    I'm trying to deploy the HttpInvoker on Weblogic 8.1 sp5, and am getting a class cast exception when it comes to initialise the DispatcherServlet:
    org.springframework.web.servlet.DispatcherServlet

    Error casting servlet: "search-remoting" to javax.servlet.Servlet java.lang.ClassCastException

    then

    javax.servlet.ServletException: Servlet class: 'org.springframework.web.servlet.
    DispatcherServlet' does not implement javax.servlet.Servlet

    I followed this strange trail to its end, and discovered that spring 2.0 is built using Servlet 2.4.
    Could this be the problem ?
    Is there an alternative to using the DispatcherServlet ?

    Cheers

  • #2
    I've rolled back to spring 1.2.8.
    That seems to have solved the problem

    Comment


    • #3
      Spring 2.0 does support Servlet 2.3 and even Servlet 2.2 for many scenarios. In your case, this simply looks like a classpath problem; did you maybe have a Servlet API jar in your WEB-INF/lib directory?

      Juergen

      Comment

      Working...
      X