Announcement Announcement Module
Collapse
No announcement yet.
Extrange behaviour of dots in external .properties Page Title Module
Move Remove Collapse
X
Conversation Detail Module
Collapse
  • Filter
  • Time
  • Show
Clear All
new posts

  • Extrange behaviour of dots in external .properties

    Hello,

    We've just encountered a strange issue with an external properties file.
    We have the properties in grails-app/conf and we do include it in the Config.groovy.

    It was working fine until we downloaded code from the cvs repository. After that, it seems that you can't get properties that are separated by dots. For example grailsApplication.config.gestion.numElementos returns [:] but grailsApplication.config.numElementos returns the text set in the properties.

    In addition, the same code is working ok in another computer, the one that uploaded the changes to the cvs repository.

    Grails version is 1.3.5

    Any ideas why is this happening and how to solve it?

    Thanks

  • #2
    Just out of interest, can you access grailsApplication.config.'gestion.numElementos'?

    I've not heard of such a problem and plenty of people use the external configuration feature. If you could create a reproducible example then please attach it to a JIRA issue so we can take a look.

    Comment


    • #3
      Extrange behaviour of dots in external .properties

      Sorry, I forgot to close the post or at least say that finally it worked, but we don't know why. After some hours and some resets it worked without changing anything.
      It's really weird, but at least it's gone. If we encounter again the problem I'll let you know.
      Thanks for your help

      Comment

      Working...
      X