Announcement Announcement Module
Collapse
No announcement yet.
Spring Security UI Question Page Title Module
Move Remove Collapse
X
Conversation Detail Module
Collapse
  • Filter
  • Time
  • Show
Clear All
new posts

  • Spring Security UI Question

    I recently installed the Spring Security UI plugin. Upon starting the app, I received "the following plugins failed to load due to missing dependencies: [springSecurityUi]" error as detailed here. To fix this, I edited the plugins block in the jQuery UI plugin dependencies.groovy file to:

    plugins {
    runtime ':jquery:1.4.2.5'
    }

    This allowed me to run the app, but when I go to the user search page, autocomplete isn't working (nor is the search link, but I am able to find users by keying in their username and using the return key). Also, when I click on a username and navigate to the Edit User page, no users are getting displayed (if I view the page source though, they are there; the div is just getting hidden by a displayed:none attribute on the tabs div). I'm thinking this is all related to the jQuery and jQuery UI plugins not being configured correctly. Anyone have any luck getting this to work?

    Anyone know what I need to do to fix this? I'm running Grails 1.3.4 on a MacBook Pro, testing in Firefox 3.6.8.

  • #2
    I did a release of the Spring Security UI and JQuery-UI plugins that resolves issues in both plugins that were causing these issues. So you need to upgrade to the latest - running 'grails install-plugin spring-security-ui' should upgrade both plugins.

    Comment

    Working...
    X