Announcement Announcement Module
Collapse
No announcement yet.
Grails Groovy Versions Page Title Module
Move Remove Collapse
X
Conversation Detail Module
Collapse
  • Filter
  • Time
  • Show
Clear All
new posts

  • Grails Groovy Versions

    Does anyone know where STS/GGTS reads the groovy version that a particular Grails version wants? I have had some problems with unit testing loading conflicting jars. The scenario is a Grails 2.3.4 project in a workspace that was configured with Groovy 2.1.6. On the surface Grails 2.3.4 appears to use either Groovy 2.0 or 2.1. However, STS sets the Groovy version in the project initially to 2.0. The unit tests fail with a conflict. If the project is set to 2.0 and and the workspace is configured to 2.0, everything works. And that's OK.

    My question is, where precisely did STS read the information in Grails to initially set the project to set the Groovy version 2.0? If it can find it, I can use that.
Working...
X