Announcement Announcement Module
Collapse
No announcement yet.
GGTS 3.2 and Grails 1.2.1 Page Title Module
Move Remove Collapse
X
Conversation Detail Module
Collapse
  • Filter
  • Time
  • Show
Clear All
new posts

  • GGTS 3.2 and Grails 1.2.1

    Hi all, I'm newbie to Grails, and have been reading a lot but am totally loss.

    I have a project developed in Grails 1.2.1, can't upgrade due to customer budget restrictions. I'm trying to configure and develop it using GGTS 3.2, but can't keep receiving compilation errors.

    First of all, is my configuration possible?

    Second, I think there is a kind of incompatibility between Grails 1.2.1 and GGTS 3.2, this is the error I get:

    Error executing script Compile: grails.util.BuildSettings.getPluginClassesDir()Lja va/io/File;
    java.lang.NoSuchMethodError: grails.util.BuildSettings.getPluginClassesDir()Lja va/io/File;
    at org.grails.ide.eclipse.runtime.GrailsBuildSettings DependencyExtractor.getPluginClassesDir(GrailsBuil dSettingsDependencyExtractor.java:63)
    at org.grails.ide.eclipse.runtime.GrailsBuildSettings DependencyExtractor.getDependencyData(GrailsBuildS ettingsDependencyExtractor.java:217)
    at org.grails.ide.eclipse.runtime.GrailsBuildSettings DependencyExtractor.writeDependencyFile(GrailsBuil dSettingsDependencyExtractor.java:201)
    at org.grails.ide.eclipse.runtime.DependencyExtractin gBuildListener.receiveGrailsBuildEvent(DependencyE xtractingBuildListener.java:79)
    at gant.Gant$_dispatch_closure4.doCall(Gant.groovy:32 4)
    at gant.Gant$_dispatch_closure6.doCall(Gant.groovy:33 4)
    at gant.Gant$_dispatch_closure6.doCall(Gant.groovy)
    at gant.Gant.withBuildListeners(Gant.groovy:344)
    at gant.Gant.this$2$withBuildListeners(Gant.groovy)
    at gant.Gant$this$2$withBuildListeners.callCurrent(Un known Source)
    at gant.Gant.dispatch(Gant.groovy:334)
    at gant.Gant.this$2$dispatch(Gant.groovy)
    at gant.Gant.invokeMethod(Gant.groovy)
    at gant.Gant.processTargets(Gant.groovy:495)
    at gant.Gant.processTargets(Gant.groovy:480)
    Error executing script Compile: grails.util.BuildSettings.getPluginClassesDir()Lja va/io/File;

    Should I be using any other configuration? I downloaded 3 different versions of GGTS/STS, non working on capable of compiling this project.

    Any guidance will be appreciated.

    Thanks!
Working...
X