Announcement Announcement Module
Collapse
No announcement yet.
JQuery Issue Grails 1.3.7 to 2.1.0 Migration Page Title Module
Move Remove Collapse
X
Conversation Detail Module
Collapse
  • Filter
  • Time
  • Show
Clear All
new posts

  • JQuery Issue Grails 1.3.7 to 2.1.0 Migration

    Hi All,

    I am facing issues related to reference, when i am trying to upgrade my existing grails application from 1.3.7 to 2.1.0

    Errors found in firebug console

    ReferenceError: jQuery is not defined
    [Break On This Error]

    ...=="hidden")return false;b=b&&b==="left"?"scrollLeft":"scrollTop";var d=false;if(...

    zg0VBw...oLGh.js (line 17)

    ReferenceError: jQuery is not defined
    [Break On This Error]

    jQuery(document).ready(function(jQuery) {




    My GSP looks as below

    <title>
    <head>
    ...............
    <gui:resources components="richEditor, dialog, utilities"/>
    <g:javascript library="jquery" />
    <jqui:resources />
    ..............

    <script>.....</script>
    </head>
    <body>


    I have used bootstrap.gsp features
    contents of bootstrap.gsp is
    <head>
    <r:require modules="scaffolding"/>
    <r:require modules='jquery' />
    ..................
    <r:layoutResources/>
    </head>
    <body>
    ............
    <r:layoutResources/>

    </body>

    Please let me know how can i get the reference of jQuery in my GSP as my code requires JQuery very badly.....

  • #2
    Dear experts please reply to this as this is a showstopper for me..... Thank you in advance....

    Comment


    • #3
      Try the User mailing list, there is a lot more activity there: http://grails.org/Mailing+Lists

      Comment


      • #4
        Thank you for the reply but no luck friend... Could you please suggest other alternative...

        Comment


        • #5
          Any help on this issue is appreciated ....

          Comment

          Working...
          X