Announcement Announcement Module
Collapse
No announcement yet.
Grails webservices! Page Title Module
Move Remove Collapse
X
Conversation Detail Module
Collapse
  • Filter
  • Time
  • Show
Clear All
new posts

  • Grails webservices!

    Dear all,

    I am using webservice with axis 1.4 in grails 2.1.1, i config in the BuildConfig.groovy as follow:


    dependencies {
    // specify dependencies here under either 'build', 'compile', 'runtime', 'test' or 'provided' scopes eg.

    // runtime 'mysql:mysql-connector-java:5.1.20'
    build 'org.apache.axis:axis:1.4'
    runtime 'org.apache.axis:axis:1.4'
    }

    when i run my application to call webservice with: run-app command, it appear error as below:

    | Error 2012-12-06 14:27:30,184 [http-bio-9000-exec-4] ERROR errors.GrailsExceptionResolver - ClassNotFoundException occurred when processing request: [GET] /wstest/testCard/charge
    org.apache.axis.client.Stub. Stacktrace follows:
    Message: org.apache.axis.client.Stub
    ......
    I checked in grails dependencies (at axis-1.4.jar library), this class: "org.apache.axis.client.Stub" is existance. But the error mean that doesnt have this class. Please help me to solved this problem.

    Thanks you so much
Working...
X