Announcement Announcement Module
Collapse
No announcement yet.
Maven failure due to dependency on org.springframework.uaa.client-1.0.1 Page Title Module
Move Remove Collapse
X
Conversation Detail Module
Collapse
  • Filter
  • Time
  • Show
Clear All
new posts

  • Maven failure due to dependency on org.springframework.uaa.client-1.0.1

    I read that many people have problems resulting from a dependency on org.springframework.uaa.client-1.0.1.

    I recently upgraded to Grails 2.x.x, and since then the Maven build fails with the following error:

    [ERROR] Failed to execute goal on project grails-project: Could not resolve dependencies for project grails-project:grails-project:war:4.0-SNAPSHOT
    : Failed to collect dependencies for [org.grails:grails-crud:jar:2.0.1 (compile), org.grails:grails-core:jar:2.0.1 (compile), org.grails:grails-spring:jar:2.0.1
    (compile), org.grails:grails-test:jar:2.0.1 (compile), org.grails:grails-web:jar:2.0.1 (compile), org.slf4j:slf4j-api:jar:1.5.8 (compile), org.slf4j:slf4j-log4
    j12:jar:1.5.8 (compile), log4j:log4j:jar:1.2.14 (provided), junit:junit:jar:4.5 (test), commons-lang:commons-lang:jar:2.4 (compile)]: Failed to read artifact de
    scriptor for org.springframework.uaa:org.springframework.uaa.cl ient:jar:1.0.1.RELEASE: Could not transfer artifact org.springframework.uaa:org.springframework.u
    aa.clientom:1.0.1.RELEASE from/to jboss (http://repository.jboss.com/maven2): Access denied to: http://repository.jboss.com/maven2/o...mework/uaa/org
    .springframework.uaa.client/1.0.1.RELEASE/org.springframework.uaa.client-1.0.1.RELEASE.pom, ReasonPhrase:Forbidden. -> [Help 1]
    The Grails installation includes the jar:
    <GRAILS_HOME>\lib\org.springframework.uaa\org.spri ngframework.uaa.client\bundles\org.springframework .uaa.client-1.0.1.RELEASE.jar.

    So what is the problem?

    Do anyone know how to prevent this failure?

    Thanks,
    Shai
Working...
X