Announcement Announcement Module
Collapse
No announcement yet.
Dependency problems upgrading to Grails 2.1.1 Page Title Module
Move Remove Collapse
X
Conversation Detail Module
Collapse
  • Filter
  • Time
  • Show
Clear All
new posts

  • Dependency problems upgrading to Grails 2.1.1

    I have a grails project that I build using Maven.
    Till now I was using Grails 1.2.2 and STS 2.8.1.

    After installing GGTS 3.1.0 and Grails 2.1.1. I tried building my project.
    Everything went well, the new grails dependencies were downloaded by maven, but then I got the following error:
    [ERROR] Failed to execute goal on project grails-project: Could not resolve dependencies for project grails-project:grails-project:war:4.0-SNAPSHOT
    : Failed to collect dependencies for [org.grails:grails-crud:jar:2.1.1 (compile), org.grails:grails-gorm:jar:2.1.1 (compile), org.grails:grails-core:jar:2.1.1 (
    compile), org.grails:grails-spring:jar:2.1.1 (compile), org.grails:grails-test:jar:2.1.1 (compile), org.grails:grails-web:jar:2.1.1 (compile), org.slf4j:slf4j-a
    pi:jar:1.5.8 (compile), org.slf4j:slf4j-log4j12:jar:1.5.8 (compile), log4j:log4j:jar:1.2.14 (provided), junit:junit:jar:4.5 (test), commons-lang:commons-lang:ja
    r:2.4 (compile)]: Failed to read artifact descriptor for org.grails:grails-gorm:jar:2.1.1: Could not transfer artifact org.grails:grails-gormom:2.1.1 from/to
    jboss (http://repository.jboss.com/maven2): Access denied to: http://repository.jboss.com/maven2/o...gorm-2.1.1.pom -> [Help 1]
    When checking the maven repository for the org.grails:grails-gorm:2.1.1 I found the following file:

    grails-gorm-2.1.1.pom.lastUpdated

    Its content:
    #NOTE: This is an internal implementation file, its format can be changed without prior notice.
    #Tue Nov 27 13:21:36 IST 2012
    http\://repository.jboss.com/maven2/.error=Could not transfer artifact org.grails\:grails-gorm\om\:2.1.1 from/to jboss (http\://repository.jboss.com/maven2)\: Access denied to\: http\://repository.jboss.com/maven2/org/grails/grails-gorm/2.1.1/grails-gorm-2.1.1.pom
    https\://repository.apache.org/content/repositories/snapshots/.error=
    https\://repository.apache.org/content/repositories/snapshots/.lastUpdated=1354012064199
    http\://maven.jahia.org/maven2/.error=
    http\://download.java.net/maven/1/.error=Could not transfer artifact org.grails\:grails-gorm\om\:2.1.1 from/to download.java.net/maven/1 (http\://download.java.net/maven/1)\: No connector available to access repository download.java.net/maven/1 (http\://download.java.net/maven/1) of type legacy using the available factories WagonRepositoryConnectorFactory
    default-http\://repository.jboss.com/maven2/.lastUpdated=1354015296230
    legacy-http\://download.java.net/maven/1/.lastUpdated=1354015296230
    http\://repo1.maven.org/maven2/.error=
    http\://repo1.maven.org/maven2/.lastUpdated=1354012064449
    http\://maven.jahia.org/maven2/.lastUpdated=1354012063402
    It seems that trying to download this dependency failed.
    I tried looking for a remote repository that hosts this version of gorm, but came short handed.

    So my questions are:
    1. Where can I find grails-gorm:2.1.1?
    2. Can I use a different version of grails-gorm with grails 2.1.1?

    Thanks,
    Shai

  • #2
    There is no grails-gorm:2.1.1.
    I removed the dependency from the Maven build.


    Cheers,
    Shai

    Comment

    Working...
    X