Announcement Announcement Module
Collapse
No announcement yet.
Grails Removing Plugins doesn't work in Eclipse or STS Page Title Module
Move Remove Collapse
X
Conversation Detail Module
Collapse
  • Filter
  • Time
  • Show
Clear All
new posts

  • Grails Removing Plugins doesn't work in Eclipse or STS

    Grails 2.1.1
    Groovy 1.8.6 or 2.0.0 depending on the try
    JDK 6 or 7 depending on the try.

    I've liked the idea of Grails because I like the Play Framework a lot and groovy is my favorite language and grails seems a bit further along, so I've tried grails several times before; Never with any success. I use MongoDB so I always try to uninstall the hibernate plugin first thing every time(I've tried uninstalling other plugins as well just for comparison, also does not work) but this never works on a clean project, I use the instructions here to do so.

    http://springsource.github.com/grail...o%20Standalone

    To be clear I uninstall the plugin and remove it from BuildConfig.groovy(and sometimes remove it from dependencies just to be safe)

    I don't even go as far as to try to install mongodb I just try to get rid of hibernate and it never works, it always shows hibernate regardless of the version(I've been trying to get into grails off and on for a year, but can never get it to work) The best I can say is that this time I tried searching for every piece of text that says hibernate and removing it and eventually it did go away, but this time that left me with extra problems, there was a file named ConfigLoader.groovy that says it can't find some hibernate class org.cfg.hibernate.Configuration which says it is indirectly referenced by the BuildConfig.class.

    I believe ConfigLoader.groovy is part of the cache plugin so I after words deleted my project started again and removed cache plugin and hibernate plugin and once again neither of them were removed.

    How does anyone else ever get grails to work with MongoDB? Do people get around this by using IntelliJ instead of STS or by using command line only and no help from the IDE? Or does no one use mongodb? I've been deleting and retrying over and over again.

    Thanks for any help.

  • #2
    I'm having the same problem with GGTS

    Version: 3.1.0.RELEASE
    Build Id: 201210061306

    I've tried removing the db-migration or the hibernate plugin and it does not show any error but the plugins are still there.

    Comment


    • #3
      In general you remove plugins by editing BuildConfig.groovy and deleting the dependency in the plugins section. There might be an entry in application.properties, so delete those rows. Then run 'grails clean' and 'grails compile' and the plugins should be gone.

      Comment

      Working...
      X