Announcement Announcement Module
No announcement yet.
Grails Dependencies error Page Title Module
Move Remove Collapse
Conversation Detail Module
  • Filter
  • Time
  • Show
Clear All
new posts

  • Grails Dependencies error

    Well, I was moving along there for a while. Back to struggling with errors.

    Seeing this intermittently now:

    The container 'Grails Dependencies' references non existing library 'C:\Users\user1\.grails\2.0.4\projects\project1\pl ugin-classes' project1 Build path Build Path Problem

  • #2
    Ok, I tried reinstalling STS. I did this by deleting the /springsource directory, and then installing a new download. I've tried both the 2.9 and the 3.0 sts branches.

    I then import the project.

    At this point, it doesn't seem to recognize the project as a grails project (crtl-alt-shft-G does nothing, there is no ability to right-click -> spring tools -> add grails nature). The .project file appears to have everything necessary:

    <?xml version="1.0" encoding="UTF-8"?>
    <name>org.eclipse.wst.common.project.facet.core.bu ilder</name>
    <nature>org.eclipse.jdt.groovy.core.groovyNature </nature>
    <nature>org.eclipse.wst.common.project.facet.core. nature</nature>


    • #3
      I reinstalled STS 3.0 and re-intalled groovy/grails and all problems are now resolved. (Mercury retrograde?)