Announcement Announcement Module
Collapse
No announcement yet.
Grails Support can not be installed from Extentions of Dashboard in STS2.8.1 Page Title Module
Move Remove Collapse
X
Conversation Detail Module
Collapse
  • Filter
  • Time
  • Show
Clear All
new posts

  • Grails Support can not be installed from Extentions of Dashboard in STS2.8.1

    Hi, guys.

    I use Windows7 and install STS2.8.1 in C:\springsource, want online integrate Grail Support (The entry from the 'Languages and Framework Tooling' section) from Extentions of Dashboard in my STS.

    I shut off all my security softwares including win7 firewall.

    But whether the install entries about Grails or Groovy can be listed totally depand on my lucky, I mean, sometimes they are listed, sometimes they are not listed at all.

    Just for try, I uninstalled STS2.8.1, emptied the whole install directory, reintalled, still in C:\springsource. But,no entry about Grails or Groovy listed either.

    Sometimes, if I am lucky, all entries about Grails or Groovy (including 'Grails Support') will be listed, but install still will terminated with some errors whatever I choose to install (usually,I choose install only 'Grails Support', sometime, also including 'Grails (current production release)' too), such as the following errors I have usually got:

    ------------error log 1---------------------
    An error occurred while collecting items to be installed
    session context wasprofile=com.springsource.sts.ide, phase=org.eclipse.equinox.internal.p2.engine.phase s.Collect, operand=, action=).
    Unable to read repository at http://dist.springsource.com/release...ndle_1.3.7.jar.
    Read timed out
    Unable to read repository at http://dist.springsource.org/snapsho...9-1800-e37.jar.
    Read timed out
    Unable to read repository at http://dist.springsource.org/snapsho...9-1800-e37.jar.
    Read timed out
    Unable to read repository at http://dist.springsource.org/snapsho...9-1800-e37.jar.
    Read timed out
    Unable to read repository at http://dist.springsource.org/snapsho...9-1800-e37.jar.
    Read timed out
    Unable to read repository at http://dist.springsource.org/snapsho...9-1800-e37.jar.
    Read timed out
    Unable to read repository at http://dist.springsource.org/snapsho...9-1800-e37.jar.
    Read timed out
    Unable to read repository at http://dist.springsource.org/snapsho...9-1800-e37.jar.
    Read timed out

    ------------error log 2---------------------
    An error occurred while collecting items to be installed
    session context wasprofile=com.springsource.sts.ide, phase=org.eclipse.equinox.internal.p2.engine.phase s.Collect, operand=, action=).
    Unable to read repository at http://dist.springsource.org/snapsho...9-1800-e37.jar.
    Read timed out
    Unable to read repository at http://dist.springsource.org/snapsho...9-1800-e37.jar.
    Read timed out
    Unable to read repository at http://dist.springsource.org/snapsho...9-1800-e37.jar.
    Read timed out

    ------------error log 3---------------------
    Problems occurred while performing installation: No repository found at http://dist.springsource.com/release...vy-grails/e3.7.

    When I used STS2.5(upgrade it to 2.6), Grails Support could be installed successfully, but why not with STS2.8.1 ?

    Groovy alwayse provide offline upgrade zip file for eclipse named Groovy-Eclipse, the lastest release is archive-2.6.0.xx-20111121-1300-e37.zip, but it not enough for Grails development.

    So, for Grails, I think the most easy way is provide an offline upgrade zip file too, anybody know where can I download this zip file ?

    This problem has blocked me for a few days, almost made me crazy, can anybody has any good solution?

    Thank you!

    Ray
Working...
X