Announcement Announcement Module
Collapse
No announcement yet.
Unresolved Dependencies Page Title Module
Move Remove Collapse
X
Conversation Detail Module
Collapse
  • Filter
  • Time
  • Show
Clear All
new posts

  • Unresolved Dependencies

    I recently installed the most current version of grails (1.4.0.1M) and wasn't even able to get out of the first chapter of Grails in Action, so I was told to go back to version 1.3.7, which I did! Now, however, I am getting the following messages:
    C:\grails/plugins/grails-xml-apis-1.3.04.jar

    ::::::::::::::::::::::::::::::::::::::::::::::

    :: UNRESOLVED DEPENDENCIES ::

    ::::::::::::::::::::::::::::::::::::::::::::::

    :: org.jboss.netty#netty;3.1.5.GA: not found

    :: junit#junit;3.8.1: not found

    :: xml-apis#xml-apis;1.3.04: not found

    ::::::::::::::::::::::::::::::::::::::::::::::

    -- C:\grails/plugins/grails-commons-digester-1.6.jar

    ::::::::::::::::::::::::::::::::::::::::::::::

    :: UNRESOLVED DEPENDENCIES ::

    ::::::::::::::::::::::::::::::::::::::::::::::

    :: commons-digester#commons-digester;1.6: not found

    ::::::::::::::::::::::::::::::::::::::::::::::

    The last one happens a couple of times. Anyone got any ideas???

  • #2
    Remove %USERPROFILE%\.ivy2\cache\* - this is a subtle problem with the way dependencies are handled between Grails 1.3.x and 2.0.

    Comment


    • #3
      RE: Unresolved Dependencies

      A very big THANK YOU!!! That did the trick!
      -Chris

      Comment

      Working...
      X