Announcement Announcement Module
Collapse
No announcement yet.
Spring-OSGi Eclipse development Page Title Module
Move Remove Collapse
X
Conversation Detail Module
Collapse
  • Filter
  • Time
  • Show
Clear All
new posts

  • Spring-OSGi Eclipse development

    Since there is no Spring-OSGi group, I am hoping this is the appropriate place to ask for help.

    I followed all the instructions for getting and building spring-osgi. No problems there. The page that tells you how to set up eclipse for spring-osgi development is helpful, but I am having problems with it. I am able to "mvn clean install" on all the required folders, and then import the two sets of projects into eclipse.

    Most of the projects imported from spring-osgi/spring-modules and spring-osgi/spring-modules/spring-required-libraries do not have a META-INF directory at the top level. If that is the case, then the plugin project will never show up in the list of plugin projects to be used when launching equinox inside the IDE. The screen-shot shows the projects in the list, but I cannot get them there because there is no META-INF/MANIFEST.MF file.

    Am I doing something wrong in the build? Should those projects include a META-INF/MANIFEST.MF that I am failing to generate?

    Thanks!

  • #2
    Ignore me, please

    Please ignore this, I posted again in a better place.

    Comment


    • #3
      Originally posted by dlaidlaw View Post
      Please ignore this, I posted again in a better place.
      Please could you give me a hint as to where this "better place" is?

      Comment


      • #4
        There is a Spring OSGI Google group.

        Comment


        • #5
          Now there is also a forum:
          http://forum.springframework.org/forumdisplay.php?f=43
          Don, I believe your problem was solved on the mailing list, right? If that's not the case, post here and we'll try to get it solved.
          Cheers,

          Comment

          Working...
          X