Announcement Announcement Module
Collapse
No announcement yet.
Bundlor dependencies not resolving Page Title Module
Move Remove Collapse
X
Conversation Detail Module
Collapse
  • Filter
  • Time
  • Show
Clear All
new posts

  • Bundlor dependencies not resolving

    Hi,
    I`m using ivy to resolve dependencies with a gant build.
    Its getting the bundlor dependencies but failing to retrieve the springframework core.Any ideas on why this could be?

    Ivy settings has:
    Code:
    <url name="com.springsource.repository.bundles.milestone">
      		<ivy pattern="http://repository.springsource.com/ivy/bundles/milestone/[organisation]/[module]/[revision]/[artifact]-[revision].[ext]"/>
      		<artifact pattern="http://repository.springsource.com/ivy/bundles/milestone/[organisation]/[module]/[revision]/[artifact]-[revision].[ext]"/>
    	  </url>
    Ivy cachepath config is:

    Code:
     ivy.cachepath(resolveId:"bundlor.classpath",
    		pathid:"bundlor.classpath",
    		organisation:"com.springsource.bundlor",
    		module:"com.springsource.bundlor.ant",
    		revision:"1.0.0.M6",
    		conf:"compile",
    		inline:"true",
    		type:"jar",
    		log:"default")
    The ivy cachepath log is:
    Code:
    [antlib:org.apache.ivy.ant:cachepath] :: resolving dependencies :: com.springsource.bundlor#com.springsource.bundlor.ant-caller;working
    [antlib:org.apache.ivy.ant:cachepath]   confs: [compile]
    [antlib:org.apache.ivy.ant:cachepath]   found com.springsource.bundlor#com.springsource.bundlor.ant;1.0.0.M6 in com.springsource.repository.bundles.milestone
    [antlib:org.apache.ivy.ant:cachepath]   found com.springsource.bundlor#com.springsource.bundlor;1.0.0.M6 in com.springsource.repository.bundles.milestone
    [antlib:org.apache.ivy.ant:cachepath]   found com.springsource.util#com.springsource.util.common;2.0.0.M3 in com.springsource.repository.bundles.milestone
    [antlib:org.apache.ivy.ant:cachepath]   found com.springsource.util#com.springsource.util.math;2.0.0.M3 in com.springsource.repository.bundles.milestone
    [antlib:org.apache.ivy.ant:cachepath]   found com.springsource.util#com.springsource.util.osgi;2.0.0.M3 in com.springsource.repository.bundles.milestone
    [antlib:org.apache.ivy.ant:cachepath]   found com.springsource.util#com.springsource.util.parser.manifest;2.0.0.M3 in com.springsource.repository.bundles.milestone
    [antlib:org.apache.ivy.ant:cachepath]   found com.springsource.bundlor#com.springsource.bundlor.blint;1.0.0.M6 in com.springsource.repository.bundles.milestone
    [antlib:org.apache.ivy.ant:cachepath] :: resolution report :: resolve 10172ms :: artifacts dl 0ms
            ---------------------------------------------------------------------
            |                  |            modules            ||   artifacts   |
            |       conf       | number| search|dwnlded|evicted|| number|dwnlded|
            ---------------------------------------------------------------------
            |      compile     |   14  |   0   |   0   |   0   ||   14  |   0   |
            ---------------------------------------------------------------------
    [antlib:org.apache.ivy.ant:cachepath] :: problems summary ::
    [antlib:org.apache.ivy.ant:cachepath] :::: WARNINGS
    [antlib:org.apache.ivy.ant:cachepath]           module not found: org.springframework#org.springframework.core;2.5.6.A
    [antlib:org.apache.ivy.ant:cachepath]   ==== libraries: tried
    [antlib:org.apache.ivy.ant:cachepath]     -- artifact org.springframework#org.springframework.core;2.5.6.A!org.springframework.core.jar:
    [antlib:org.apache.ivy.ant:cachepath]     C:\projects\easyb\trunk\easyb/repository/org.springframework.core-2.5.6.A.jar
    [antlib:org.apache.ivy.ant:cachepath]   ==== easybrepo: tried
    [antlib:org.apache.ivy.ant:cachepath]     -- artifact org.springframework#org.springframework.core;2.5.6.A!org.springframework.core.jar:
    [antlib:org.apache.ivy.ant:cachepath]     http://www.easyb.org/repo/org.spring...re-2.5.6.A.jar
    [antlib:org.apache.ivy.ant:cachepath]   ==== ibiblio: tried
    [antlib:org.apache.ivy.ant:cachepath]     -- artifact org.springframework#org.springframework.core;2.5.6.A!org.springframework.core.jar:      
    .............. 
    
    ::::::::::::::::::::::::::::::::::::::::::::::
    ::          UNRESOLVED DEPENDENCIES         ::
    ::::::::::::::::::::::::::::::::::::::::::::::
    :: org.springframework#org.springframework.core;2.5.6.A: not found
    :: org.objectweb.asm#com.springsource.org.objectweb.asm;3.1.0: not found
    :: org.objectweb.asm#com.springsource.org.objectweb.asm.tree;3.1.0: not found
    :: org.objectweb.asm#com.springsource.org.objectweb.asm.commons;3.1.0: not found
    :: org.eclipse.osgi#org.eclipse.osgi;3.5.100.v20090629: not found
    :: org.springframework.ws#org.springframework.xml;1.5.5.A: not found
    :: org.springframework#org.springframework.beans;2.5.6.A: not found
    ::::::::::::::::::::::::::::::::::::::::::::::

  • #2
    Using S3 Browse it looks like the only apis available are the 3.0 ones which is why they can`t be found.

    http://s3browse.com/explore/reposito...ramework.core/

    Comment


    • #3
      I`ve created Jira http://jira.springframework.org/browse/OSGI-784
      for this issue

      Comment


      • #4
        Apologies, After clearing my Ivy cache it worked.

        Comment

        Working...
        X