Announcement Announcement Module
No announcement yet.
RepositoryFactory service was not available. Page Title Module
Move Remove Collapse
Conversation Detail Module
  • Filter
  • Time
  • Show
Clear All
new posts

  • RepositoryFactory service was not available.

    Hi all,
    in my newly installed dm tooling

    * SpringSource dm Server Tools (required)

    * Eclipse IDE for Java EE Developers epp.package.jee
    * Eclipse Platform 3.5.1.M20090917-0800 org.eclipse.platform.ide
    * Java EE IDE Feature

    I get the following error:

    An internal error occurred during: "Downloading bundles and libraries from Enterprise Bundle Repository".
    RepositoryFactory service was not available. Is the repository bundle installed and started?

    java.lang.IllegalStateException: RepositoryFactory service was not available. Is the repository bundle installed and started?
    at geFilteringRepository.getRepositoryFactory(SystemP
    at geFilteringRepository.createRepository(SystemPacka
    at geFilteringRepository.<init>(SystemPackageFilterin
    at<i nit>(
    at pendencyLocator.<init>(
    at pendencyLocator20.<init>( 44)
    at com.springsource.server.ide.runtime.core.ServerUti ls.createDependencyLocator(
    at com.springsource.server.ide.runtime.core.ServerUti ls.createDependencyLocator(
    at com.springsource.server.ide.jdt.internal.core.clas spath.ServerClasspathContainer.createDependencyLoc ator(
    at com.springsource.server.ide.jdt.internal.core.clas spath.ServerClasspathContainer.refreshClasspathEnt ries(
    at com.springsource.server.ide.jdt.internal.core.util .ClasspathUtils.updateClasspathContainer(Classpath
    at com.springsource.server.ide.jdt.internal.core.clas spath.ServerClasspathContainerUpdateJob.runInWorks pace(
    at org.eclipse.core.internal.resources.InternalWorksp
    at ava:55)

    Any help is appreciated.

  • #2
    After manually starting the bundle in the OSGi console it works.
    This behavior is not very user friendly

    765 RESOLVED com.springsource.repository_2.0.0.CI-265

    > start 765

    765 ACTIVE com.springsource.repository_2.0.0.CI-265


    • #3
      I've got the exact same configuration and am seeing the same problem.


      • #4
        Thanks for reporting the problem. I believe that Christian has fixed this issue in the latest dm Server tools available from the update site. The fix should also be available in STS 2.2.0 which was released yesterday.

        Please give those a try, and let us know if you're still having problems.