Announcement Announcement Module
Collapse
No announcement yet.
What version of STS/dm server tools works with server 2.0.0.M3? Page Title Module
Move Remove Collapse
X
Conversation Detail Module
Collapse
  • Filter
  • Time
  • Show
Clear All
new posts

  • What version of STS/dm server tools works with server 2.0.0.M3?

    Hi,

    yesterday I downloaded the latest version of the dm server (2.0.0.M3) and, following the programmer's guide, I also downloaded SpringSource Tool Suite (STS) 2.1.0.RC1.

    The problem is that with that version of STS I am unable to deploy my Eclipse projects to the server instance by drag and drop. Although annoying, this is no reason for alarm since right-clicking the server and selecting "Add and remove" appears to work. _However_, most of my projects don't seem to be recognized at all by the server tools (they do not show up in the add/remove dialog), despite that I have added the OSGi Bundle Project Nature to the project.

    Is this a known issue? Am I using an unsupported combination of server and STS/dm server tool versions? What is the preferred STS/dm server tools version for working with dm server 2.0.0.M3?

    kind regards, Peter

  • #2
    Originally posted by peter.gardfjell View Post
    Hi,

    yesterday I downloaded the latest version of the dm server (2.0.0.M3) and, following the programmer's guide, I also downloaded SpringSource Tool Suite (STS) 2.1.0.RC1.

    The problem is that with that version of STS I am unable to deploy my Eclipse projects to the server instance by drag and drop. Although annoying, this is no reason for alarm since right-clicking the server and selecting "Add and remove" appears to work.
    This is a known problem that should now be fixed, although not in the version of dm Server tools that's included in STS 2.1.0.RC1.

    _However_, most of my projects don't seem to be recognized at all by the server tools (they do not show up in the add/remove dialog), despite that I have added the OSGi Bundle Project Nature to the project.

    Is this a known issue? Am I using an unsupported combination of server and STS/dm server tool versions? What is the preferred STS/dm server tools version for working with dm server 2.0.0.M3?
    This sounds like a new problem, I certainly haven't seen this happening. Could you please open a JIRA against the dm Server tools.

    As for the preferred version, I've been using 2.1.0.RC1 quite successfully with dm Server 2.0, apart from the drag and drop problem described above. If you'd like to try a nightly build to pick up the drag and drop fix the update site is http://dist.springsource.com/snapshot/DMS-TOOLS/nightly

    Comment


    • #3
      Thanks Andy.

      I tried the latest snapshot of dm server tools (2.0.0.200907160100-CI-R256-B87) from the snapshot update site. This version obviously has issues since I couldn't even create a SpringSource dm server instance under the Server creation wizard. The SpringSource choice simply wasn't there.

      That's besides the point though, since somehow my projects are now recognized by the dm server tools again (version 2.0.0.200906231227-RC1). As I started out this morning I encountered the same problems as I described in the previous mail (the dm server tools claiming that no deployable modules were available despite all projects being decorated with the OSGi bundle project nature). I had started writing down a new mail with questions about my problems when I returned to Eclipse and all of a sudden the projects could be added to the server. Without me doing anything.

      This makes me wonder if there could be some time-consuming initialization (or the likes) that need to be carried out by the dm server tools before being able to handle project adding to the server instance? It would be nice if someone could shed some light on this, since I don't feel comfortable with things being broken and then automagically starting to work again.

      regards, Peter

      Comment


      • #4
        Peter,

        there is no long running initialization that should affect the ability to deploy a project to a dm Server. There might be a problem with WTP; what version of Eclipse are you using (3.4 or 3.5)?

        Did you install the latest nightly into STS 2.1.0.RC1? After the installation there was no server wizard for dm Server? I'll look into this as it seams to be an installation problem.

        Christian

        Comment


        • #5
          I am currently using a plain Eclipse 3.5 JEE installation with SpringSource dm server tools version 2.0.0.200906231227-RC1.

          The attempt to install the latest nightly snapshot version of dm server tools was performed against that Eclipse installation (not STS).

          regards, Peter

          Comment


          • #6
            I hit this myself yesterday, and Christian was then able to reproduce it and get a fix into STS. Note that this will only make it in there for releases _after_ 2.1.0.RC2.

            Note that I actually hit the issue against dm Server 1.0.2, not 2.x, and once I exited Eclipse and came back in, I was able to deploy the bundle that was previously ignored and unavaiable.

            Colin

            Comment

            Working...
            X