Announcement Announcement Module
Collapse
No announcement yet.
Bundlor Maven plugin dependencies Page Title Module
Move Remove Collapse
X
Conversation Detail Module
Collapse
  • Filter
  • Time
  • Show
Clear All
new posts

  • Bundlor Maven plugin dependencies

    I'm having a hard time getting the Bundlor Maven plugin dependencies through my Nexus repository manager. The artifacts missing are:

    com.springsource.util:com.springsource.util.osgi:j ar:1.5.0.BUILD-SNAPSHOT
    com.springsource.util:com.springsource.util.io:jar :1.5.0.BUILD-SNAPSHOT
    com.springsource.util:com.springsource.util.math:j ar:1.5.0.BUILD-SNAPSHOT

    My Nexus repo manager is opening up for these four urls:

    http://repository.springsource.com/m...ndles/snapshot
    http://repository.springsource.com/m...dles/milestone
    http://repository.springsource.com/m...undles/release
    http://repository.springsource.com/m...ndles/external

    Any thoughts?

  • #2
    Moved thread to dm Server tooling forum.

    Comment


    • #3
      strange bundlor maven plugin dependency

      Hi,

      I have exactly the same problem with the bundlor maven plugin dependency
      when i try to build the spring-dm-1.2 from the sources.

      Our company nexus repository has problems resolving the
      com.springsource.util:com.springsource.util.math:j ar:1.5.0.BUILD-SNAPSHOT
      com.springsource.util:com.springsource.util.io:jar :1.5.0.BUILD-SNAPSHOT
      artifacts.

      From which maven repository can this artifact be resolved ?


      Any help appreciated,
      Dirk

      Comment


      • #4
        Those dependencies are all in http://repository.springsource.com/m...ndles/snapshot (which was mentioned in the original post). You can browse the repository here to check: http://s3browse.com/explore/reposito...ndles/snapshot.

        I have no idea what might be wrong with Nexus, but the jars are there, and it seems to work without the Nexus in the way.

        Comment


        • #5
          Bundlor Maven plugin dependencies

          Hi Dave,

          Thanks for the quick response. I browsed the URL you mentioned but could not find

          Path to dependency:
          1) com.springsource.bundlor:com.springsource.bundlor. maven:maven-plugin:1.0.0.M2
          2) com.springsource.util:com.springsource.util.io:jar :1.5.0.BUILD-SNAPSHOT

          I am a little confused.
          Regards,
          Dirk

          Comment


          • #6
            ok guys, I restarted Nexus this morning, and it did the trick. Was it the restart? is it something else?

            Anyhow, for Nexus users, make sure you have the 4 Spring repositories mentionned earlier in the public group when developing with SpringDM.

            JS.

            Comment


            • #7
              Originally posted by dirk.dinger View Post
              1) com.springsource.bundlor:com.springsource.bundlor. maven:maven-plugin:1.0.0.M2
              Try here for browseable link:

              http://s3browse.com/explore/reposito...source.bundlor

              Originally posted by dirk.dinger View Post
              2) com.springsource.util:com.springsource.util.io:jar :1.5.0.BUILD-SNAPSHOT
              Try here for browseable link:

              http://s3browse.com/explore/reposito...source.util.io

              Did you set your Nexus up the same way as jsbournival?

              Comment


              • #8
                Thanks

                thanks for all

                Comment

                Working...
                X