Announcement Announcement Module
Collapse
No announcement yet.
Problem about transfer from standard bundle Page Title Module
Move Remove Collapse
X
Conversation Detail Module
Collapse
  • Filter
  • Time
  • Show
Clear All
new posts

  • Problem about transfer from standard bundle

    Now I try to use SpringSource DM Server, and transfer our bundle to Spring DM Server powered bundle.

    But I find some problem:
    (1) In order to manage Dependencies in Eclipse GUI, I have to change the Require-Bundle to Import-Bundle in MANIFEST.MF.
    (2) Spring DM Tool can't find the Require(or Import) bundle, although these bundles are added by Eclipse GUI.

  • #2
    jiangyubao,

    (1) There is no requirement to change from Require-Bundle to Import-Bundle to use an OSGi bundle on dm Server. Having said that we do recommend to use Import-Bundle because of its cleaner semantics.

    Where and why do you think that this change is a requirement.

    (2) Can you provide a little bit more details about this problem. I'm not sure that I understand the problem.

    Are you saying that if you Import-Bundle: org.springframework.core you get the problem marker saying that the bundle cannot be resolved. If that is the case have you defined a target runtime for your bundle project?

    Christian

    Comment


    • #3
      Thanks for your reply!

      I known how to resolve this problem. It's another problem decribed by :

      http://forum.springframework.org/showthread.php?t=61559

      Comment


      • #4
        I am sorry that this is my first time to use this Tool, and I had resolved this problem.

        Thanks for your reply.

        Comment

        Working...
        X