Announcement Announcement Module
Collapse
No announcement yet.
EBR as remote repository problems Page Title Module
Move Remove Collapse
X
Conversation Detail Module
Collapse
  • Filter
  • Time
  • Show
Clear All
new posts

  • EBR as remote repository problems

    I've been trying to configure the EBR as a remote repository in dm Server 2.0.1.RELEASE, but have been having some trouble.

    1. Using the following configuration:
    Code:
    ebr.type=remote
    ebr.uri=http://repository.springsource.com/index/external.orf
    ebr.indexRefreshInterval=500
    
    chain=ext,usr,ebr
    It works fine on a clean start, but on subsequent startups I keep getting (I've even tried downloading the missing bundle and putting it in repository/usr and lib):

    Code:
    [2010-04-09 16:39:16.637] system-artifacts             <DE0000I> Installing bundle 'com.springsource.kernel.deployer.dm' version '2.0.1.RELEASE'. 
    [2010-04-09 16:40:32.856] system-artifacts             <DE0002E> Installation of plan 'com.springsource.kernel.userregion.springdm' version '2.0.1' failed. com.springsource.kernel.deployer.core.DeploymentException: commit failed
    	at com.springsource.kernel.install.pipeline.stage.resolve.internal.CommitStage.process(CommitStage.java:50)
    	at com.springsource.kernel.install.pipeline.internal.StandardPipeline.doProcessTree(StandardPipeline.java:71)
    	at com.springsource.kernel.install.pipeline.internal.CompensatingPipeline.doProcessTree(CompensatingPipeline.java:81)
    	at com.springsource.kernel.install.pipeline.stage.AbstractPipelineStage.process(AbstractPipelineStage.java:50)
    	at com.springsource.kernel.install.pipeline.internal.StandardPipeline.doProcessTree(StandardPipeline.java:71)
    	at com.springsource.kernel.install.pipeline.stage.AbstractPipelineStage.process(AbstractPipelineStage.java:50)
    	at com.springsource.kernel.deployer.core.internal.PipelinedApplicationDeployer.driveInstallPipeline(PipelinedApplicationDeployer.java:277)
    	at com.springsource.kernel.deployer.core.internal.PipelinedApplicationDeployer.doInstall(PipelinedApplicationDeployer.java:160)
    	at com.springsource.kernel.deployer.core.internal.PipelinedApplicationDeployer.install(PipelinedApplicationDeployer.java:132)
    	at com.springsource.kernel.deployer.core.internal.PipelinedApplicationDeployer.deploy(PipelinedApplicationDeployer.java:196)
    	at com.springsource.kernel.userregion.internal.InitialArtifactDeployer$ArtifactDeployingRunnable.deployArtifacts(InitialArtifactDeployer.java:164)
    	at com.springsource.kernel.userregion.internal.InitialArtifactDeployer$ArtifactDeployingRunnable.run(InitialArtifactDeployer.java:154)
    	at java.lang.Thread.run(Thread.java:619)
    .
    .
    .
    Caused by: java.lang.ClassNotFoundException: javax.persistence.spi.ProviderUtil
    	at org.eclipse.osgi.internal.loader.BundleLoader.findClassInternal(BundleLoader.java:448)
    	at org.eclipse.osgi.internal.loader.BundleLoader.findClass(BundleLoader.java:410)
    	at org.eclipse.osgi.internal.loader.BundleLoader.findClass(BundleLoader.java:398)
    	at org.eclipse.osgi.internal.baseadaptor.DefaultClassLoader.loadClass(DefaultClassLoader.java:105)
    	at com.springsource.kernel.userregion.internal.equinox.KernelBundleClassLoader.loadClass(KernelBundleClassLoader.java:145)
    	... 63 common frames omitted
    2. I can get around the above problem with the following configuration:
    Code:
    ebr-release.type=remote
    ebr-release.uri=http://repository.springsource.com/index/release.orf
    ebr-release.indexRefreshInterval=500
    
    ebr-external.type=remote
    ebr-external.uri=http://repository.springsource.com/index/external.orf
    ebr-external.indexRefreshInterval=500
    
    chain=ext,usr,ebr-release,ebr-external
    But in this case it takes at least 2.5 minutes each time I start the server before it gets past the deployer bundle. And when I try to deploy a plan file, I'm still missing classes:

    Caused by:
    Code:
    com.springsource.kernel.osgi.framework.UnableToSatisfyBundleDependenciesException: Unable to satisfy dependencies of bundle 'app-1.2-app.web' at version '1.2.0': Import-Bundle with symbolic name 'org.springframework.security.cas' in version range '[3.0.0.RELEASE, oo)' could not be satisfied
    Any suggestions?

  • #2
    We do not recommend adding the EBR to repository chains for a couple of reasons.

    Firstly, we found that starting dm Server with the EBR in the repository chain causes some 200 Mb of optional dependencies to be downloaded during dm Server startup, which is undesirable, very slow, and therefore leads to instability (timeouts etc.).

    Secondly, the EBR indexes do not get automatically updated and so it is not in general possible to reference all the content of the EBR reliably. We hope to improve this situation as the EBR evolves, e.g. if it moves to Eclipse.

    Comment

    Working...
    X