Announcement Announcement Module
Collapse
No announcement yet.
Dm shell doesnt work on Linux Page Title Module
Move Remove Collapse
X
Conversation Detail Module
Collapse
  • Filter
  • Time
  • Show
Clear All
new posts

  • Dm shell doesnt work on Linux

    I have downloaded dm kernel and started it in Windows. Then when i connect using putty to 2401 I am able to connect to Dm shell

    But teh same fails in vm node(with OS - Red Hat Enterprise Linux Server release 5.2 (Tikanga))

    It connects asks for username - i enter username followed by password , it just gets stuck and doesn't proceed.

    I have confirmed with the IT Support and they have confirmed that the port is enabled on that machine.

    How do i solve this ?

  • #2
    Hello,

    Thanks for reporting the problem.

    Just to clarify, in both cases you are connecting from a Windows machine using Putty?
    It works when the server is running on Windows but not when it is on a virtual box running Red Hat?

    Thanks, Chris.

    Comment


    • #3
      Yes , in both cases i tried connecting from Windows using putty.

      Yes it worked on windows but not on linux.

      Comment


      • #4
        Hi,

        Thanks for that. It's unusual that it is that way round, we have had trouble with the sshd server when running on windows but not so much on Linux. We have also had issues with Putty and there are two things you can try.

        In Putty, enable the automatic CR option. See here: http://the.earth.li/~sgtatham/putty/...ml#config-crlf

        If that dosn't work, give the cygwin ssh client a try. We have had far fewer issues with that one.

        Apart from that you will just have to wait for future releases of the server under the Virgo name as we will keep moving up the version of Apache mini and sshd that we use.

        Chris.

        Comment


        • #5
          With some more effort i am able to figure out the exact case

          In Linux i am running the process in background and that seems to be the issue.

          ./bin/startup.sh -clean &

          When i dont run in background i am able to connect even in linux.

          But i want the process in background. Any help on that would be appreciated.

          Comment


          • #6
            Hi,

            I've been able to recreate this on a Mac, no virtual machine. Will investigate further.

            Chris.

            Comment


            • #7
              Thanks . Looking forward for a solution :-).

              Comment


              • #8
                Hi,

                I have failed to re-create this problem in a really simple test app that uses the sshd infrastructure so I suspect that it is somthing we are doing. To that end I have raised an issue to track the problem. https://issuetracker.springsource.com/browse/DMS-2407

                In the mean time, if you need to run the dm Server as a background process have you tried using the service wrapper that comes with the dm Server. This will start the dm Server as a UNIX background process for you. The documentation for it is here,

                http://static.springsource.org/s2-dm...de.html#d0e759

                Let me know if this is of any help.

                Chris.

                Comment


                • #9
                  Thanks for that .It should surely help. Will try out the wrapper to run in background and let u know in case of issues.

                  Comment


                  • #10
                    Great it seems to work fine :-)

                    Comment


                    • #11
                      Got a issues with it.

                      I use to modify my dmk.sh (adding classpath,jmx options and also other jvm parameters).

                      Now when i run this spring Dm as a service in linux , I see that dmk.sh doesnt get invoked.

                      So how do I add these startup parameters ?

                      Also how do i specify my custom config directory ?(as i want to run multiple instances)

                      Comment


                      • #12
                        Hi,

                        The behaviour of the service wrapper is configured via the wrapper.conf file. It may be possible to get the behaviour your after using that. I would start by trying to get what you want out of the service wrapper by passing arguments in to the dm Server on the command line then migrate them over to the wrapper conf file.

                        Chris.

                        Comment


                        • #13
                          One more observation was

                          1. When I run the startup.sh with nohup, dm shell is working fine.

                          2. Also if i use a wrapper script and run in background it works fine. i. e
                          test.sh having
                          ./springsource-dm-kernel-2.0.0.RELEASE/bin/startup.sh -clean &

                          Comment


                          • #14
                            Hi,

                            Thanks for the info. Do you mean the converse that the shell is not working when running startup.sh &

                            If you feel there is an improvement here could you qualify it a bit and I'll gladly raise a bugzilla for it. Feel free to youself.

                            https://bugs.eclipse.org/bugs/buglis...;product=Virgo

                            Thanks, Chris.

                            Comment


                            • #15
                              Yes exactly, when i run as startup.sh & , dm shell just hangs.

                              I have posted the BUG as suggested under VIRGO.

                              https://bugs.eclipse.org/bugs/show_bug.cgi?id=308776

                              Comment

                              Working...
                              X