Announcement Announcement Module
Collapse
No announcement yet.
[Slices] and dm Server M5 Page Title Module
Move Remove Collapse
X
Conversation Detail Module
Collapse
  • Filter
  • Time
  • Show
Clear All
new posts

  • [Slices] and dm Server M5

    Can Slices be used with M5? If not, how soon?

  • #2
    I found dms-m5 branch and that thing just worked!

    If anyone is interested:
    1. pull down and build dms-m5 branch from slices repo
    Code:
    git checkout --track -b branch dms-m5 origin/dms-m5
    2. build it
    Code:
    cd build-slices
    ant clean jar package
    3. modify $SERVER/config/com.springsource.kernel.properties
    Code:
    #deployer.systemArtifacts=	repository:plan/com.springsource.server.web
    deployer.systemArtifacts=	repository:plan/com.springsource.server.web,repository:plan/com.springsource.osgi.slices
    4. start dm Server

    I ended up testing this with a petclinic sample app. To build that I had to add
    Code:
    		<dependency org="org.eclipse.osgi" name="org.eclipse.osgi" rev="${org.eclipse.osgi}" conf="compile->compile"/>
    in /samples/slices-petclinic/com.springsource.slices.petclinic.host/ivy.xml

    Will follow up if I see issues with my own apps.
    Last edited by dsklyut; Oct 14th, 2009, 09:53 PM.

    Comment


    • #3
      Further observations:

      Application configured in a scoped plan with a host webapp and 1 slice, does not deploy right now.

      Looks like slices deployer is not used to deploy a slice, but a regular web-app deployer is. Seeing msg in console:

      Code:
      [2009-10-14 11:24:02.698] Thread-2                     <WE0000I> Starting web bundle '****plan-1.1.0.DEV-SNAPSHOT-****.web' context path '/****.web-1.1.0.DEV-SNAPSHOT'.
      Looks like manifest entries for slices are not picked up.
      I guess just dropping a slice plan into pickup is not enough.

      Comment


      • #4
        Dmitry, first of all, I should say thank you for trying this out on M5: you've pretty much written my blog post on how to use Slices on M5 for me!

        Using a Slice from within a scoped plan should work. If it doesn't, then it sounds like you found a bug. Apologies for that. My guess would be that it's the scoping logic that's causing the problem. Does it work for you if the plan is not scoped?

        Comment


        • #5
          A little further research:

          1. Transformer ordering is not correct (I think).
          SliceTransformer is executed before PlanResolver. So I bumped ranking of SliceTransformer by 1.

          2. There is still an issue described in http://forum.springsource.org/showthread.php?t=74704.
          Matching host bundle name to bundle.symbolicName is broke again.
          Last edited by dsklyut; Oct 16th, 2009, 12:15 PM.

          Comment


          • #6
            Created DMS-1756 and updated DMS-1134

            Comment


            • #7
              One final issue:

              When dm starts up with slices, you can see a message for com.springsource.server.web plan - Install failed. Is that because slices pull in classes from com.springsource.server.web plan and bundles are started by the time com.springsource.server.web is processed?

              I tried changing the order in com.springsource.kernel.properties, but the same message in the logs. Everything works, but just not pretty.

              Code:
              deployer.systemArtifacts=	repository:plan/com.springsource.server.web,repository:plan/com.springsource.osgi.slices
              and
              Code:
              deployer.systemArtifacts=repository:plan/com.springsource.osgi.slices, repository:plan/com.springsource.server.web
              Code:
              [2009-10-16 16:44:34.922] startup-tracker              <KE0001I> Kernel starting. 
              [2009-10-16 16:44:40.965] startup-tracker              <KE0002I> Kernel started. 
              [2009-10-16 16:44:41.542] Thread-2                     <SH0001I> dm Kernel ssh shell available on port 2402. 
              [2009-10-16 16:44:41.774] system-artifacts             <DE0056I> Installing plan 'com.springsource.osgi.slices' version '2.0.0'. 
              [2009-10-16 16:44:44.035] system-artifacts             <TC0000I> Starting Tomcat. 
              [2009-10-16 16:44:44.124] system-artifacts             <TC0001I> Creating HTTP/1.1 connector with scheme http on port 8080. 
              [2009-10-16 16:44:44.142] system-artifacts             <TC0001I> Creating HTTP/1.1 connector with scheme https on port 8443. 
              [2009-10-16 16:44:44.151] system-artifacts             <TC0001I> Creating AJP/1.3 connector with scheme http on port 8009. 
              [2009-10-16 16:44:44.389] system-artifacts             <DE0057I> Installed bundle 'com.springsource.osgi.slices.api' version '1.0.0.BUILD-20091016165239'. 
              [2009-10-16 16:44:44.454] system-artifacts             <DE0057I> Installed bundle 'com.springsource.osgi.slices.core' version '1.0.0.BUILD-20091016165239'. 
              [2009-10-16 16:44:44.475] system-artifacts             <DE0057I> Installed plan 'com.springsource.osgi.slices' version '2.0.0'. 
              [2009-10-16 16:44:44.632] system-artifacts             <DE0059I> Starting plan 'com.springsource.osgi.slices' version '2.0.0'. 
              [2009-10-16 16:44:44.645] system-artifacts             <DE0059I> Starting bundle 'com.springsource.osgi.slices.api' version '1.0.0.BUILD-20091016165239'. 
              [2009-10-16 16:44:44.662] system-artifacts             <DE0060I> Started bundle 'com.springsource.osgi.slices.api' version '1.0.0.BUILD-20091016165239'. 
              [2009-10-16 16:44:44.700] system-artifacts             <DE0059I> Starting bundle 'com.springsource.osgi.slices.core' version '1.0.0.BUILD-20091016165239'. 
              [2009-10-16 16:44:44.870] Thread-3                     <DE0060I> Started bundle 'com.springsource.osgi.slices.core' version '1.0.0.BUILD-20091016165239'. 
              [2009-10-16 16:44:44.882] Thread-3                     <DE0060I> Started plan 'com.springsource.osgi.slices' version '2.0.0'. 
              [2009-10-16 16:44:45.021] system-artifacts             <DE0056I> Installing plan 'com.springsource.server.web' version '2.0.0'. 
              [2009-10-16 16:44:45.394] system-artifacts             <DE0058E> Install failed for plan 'com.springsource.server.web' version '2.0.0'.

              Comment

              Working...
              X