Announcement Announcement Module
Collapse
No announcement yet.
AXIS + SSL + Spring Server Page Title Module
Move Remove Collapse
X
Conversation Detail Module
Collapse
  • Filter
  • Time
  • Show
Clear All
new posts

  • AXIS + SSL + Spring Server

    As in our project (bundle) we need to access webservice using secured connection.
    We have generated web service client classes using Axis and tested connection using JUnit. but during use of that bundle under Spring Server we have strange exception:

    Caused by: com.springsource.server.osgi.framework.ServerClass NotFoundException: javax.crypto.NoSuchPaddingException in ServerBundleClassLoader: [bundle=ewsaccess_0.3.0]
    at com.springsource.server.osgi.framework.equinox.Ser verBundleClassLoader.loadClass(ServerBundleClassLo ader.java:136)
    at java.lang.ClassLoader.loadClass(Unknown Source)
    at java.lang.ClassLoader.loadClassInternal(Unknown Source)
    ... 98 more
    Caused by: java.lang.ClassNotFoundException: javax.crypto.NoSuchPaddingException

    thanks in advance for any help.


    btw this is our bundle's manifest.fm content:
    Manifest-Version: 1.0
    Bundle-Version: 0.3
    Bundle-Name: e services access
    Bundle-ManifestVersion: 2
    Bundle-Description: PPP
    Bundle-SymbolicName: ewsaccess
    Import-Package: javax.xml.rpc;version="[1.1.0,1.1.0]",
    javax.xml.rpc.encoding;version="[1.1.0,1.1.0]",
    org.apache.axis;version="[1.4.0,1.4.0]",
    org.apache.axis.client;version="[1.4.0,1.4.0]",
    org.apache.axis.constants;version="[1.4.0,1.4.0]",
    org.apache.axis.description;version="[1.4.0,1.4.0]",
    org.apache.axis.encoding;version="[1.4.0,1.4.0]",
    org.apache.axis.encoding.ser;version="[1.4.0,1.4.0]",
    org.apache.axis.message;version="[1.4.0,1.4.0]",
    org.apache.axis.soap;version="[1.4.0,1.4.0]",
    org.apache.axis.utils;version="[1.4.0,1.4.0]"
    Export-Package: ppp.webservices.e;
    uses:="ppp.webservices.eCommons,
    org.apache.axis.client,
    ppp.webservices.eService,
    javax.xml.namespace",
    ppp.webservices.eCommons;uses:="org.apache.axis.de scription,org.apache.axis.encoding,javax.xml.names pace",
    ppp.webservices.eService;
    uses:="org.apache.axis.client,
    org.apache.axis,
    org.apache.axis.description,
    org.apache.axis.encoding,
    javax.xml.rpc,
    javax.xml.namespace"
    Bundle-Vendor: PPP
    Bundle-RequiredExecutionEnvironment: J2SE-1.5

  • #2
    The error message:

    Code:
    Caused by: com.springsource.server.osgi.framework.ServerClassNotFoundException: javax.crypto.NoSuchPaddingException in ServerBundleClassLoader: [bundle=ewsaccess_0.3.0]
    is indicating that the class javax.crypto.NoSuchPaddingException could not be loaded by the class loader for the bundle ewaccess version 0.3.0. Typically this is as a result of a missing import in that bundle's manifest. E.g. in this case an import for the javax.crypto package would be necessary to make the NoSuchPaddingException class available to the bundle.

    Looking at your manifest, it doesn't appear to import the javax.crypto package. Try adding an import for it and hopefully that should fix this problem.

    Comment

    Working...
    X