Announcement Announcement Module
Collapse
No announcement yet.
error on debug S2AP start Page Title Module
Move Remove Collapse
X
Conversation Detail Module
Collapse
  • Filter
  • Time
  • Show
Clear All
new posts

  • error on debug S2AP start

    Hi *,

    I'm able to run S2AP in normal mode.
    It takes long time but starts without any errors.
    If I run S2AP in debug mode then I get an error.

    I use RC1 and latest nightly builds of Spring IDE and AP Tool.



    Here is a bit of the console output (dump is to big and can't be sent):


    ......
    [2008-07-31 13:02:43.812] Deployer Recovery <SPSC1000I> Creating web application '/'.
    [2008-07-31 13:02:43.828] async-delivery-thread-1 <SPSC1001I> Starting web application '/'.
    [2008-07-31 13:02:49.234] Deployer Recovery <SPDE0010I> Deployment of 'platform.admin.splash-1.0.0.RC1.war' version '0' completed.
    [2008-07-31 13:02:49.875] platform-dm-7 <SPFF0002I> Wrote dump file "D:serversspringsource-ap-1.0.0.RC1serviceabilitydump2008-07-31_13-02-42.dump"
    com.springsource.platform.deployer.core.FatalDeplo ymentException: Deployer recovery appears not to have completed.
    at com.springsource.platform.deployer.hot.HotDeployer .start(HotDeployer.java:108)
    at sun.reflect.NativeMethodAccessorImpl.invoke0(Nativ e Method)
    at sun.reflect.NativeMethodAccessorImpl.invoke(Unknow n Source)
    at sun.reflect.DelegatingMethodAccessorImpl.invoke(Un known Source)
    at java.lang.reflect.Method.invoke(Unknown Source)
    at org.springframework.beans.factory.support.Abstract AutowireCapableBeanFactory.invokeCustomInitMethod( AbstractAutowireCapableBeanFactory.java:1413)
    at org.springframework.beans.factory.support.Abstract AutowireCapableBeanFactory.invokeInitMethods(Abstr actAutowireCapableBeanFactory.java:1374)
    at org.springframework.beans.factory.support.Abstract AutowireCapableBeanFactory.initializeBean(Abstract AutowireCapableBeanFactory.java:1334)
    at org.springframework.beans.factory.support.Abstract AutowireCapableBeanFactory.doCreateBean(AbstractAu towireCapableBeanFactory.java:473)
    at org.springframework.beans.factory.support.Abstract AutowireCapableBeanFactory$1.run(AbstractAutowireC apableBeanFactory.java:409)
    at java.security.AccessController.doPrivileged(Native Method)
    at org.springframework.beans.factory.support.Abstract AutowireCapableBeanFactory.createBean(AbstractAuto wireCapableBeanFactory.java:380)
    at org.springframework.beans.factory.support.Abstract BeanFactory$1.getObject(AbstractBeanFactory.java:2 64)
    at org.springframework.beans.factory.support.DefaultS ingletonBeanRegistry.getSingleton(DefaultSingleton BeanRegistry.java:221)
    at org.springframework.beans.factory.support.Abstract BeanFactory.doGetBean(AbstractBeanFactory.java:261 )
    at org.springframework.beans.factory.support.Abstract BeanFactory.getBean(AbstractBeanFactory.java:185)
    at org.springframework.beans.factory.support.Abstract BeanFactory.getBean(AbstractBeanFactory.java:164)
    at org.springframework.beans.factory.support.DefaultL istableBeanFactory.preInstantiateSingletons(Defaul tListableBeanFactory.java:429)
    at org.springframework.context.support.AbstractApplic ationContext.finishBeanFactoryInitialization(Abstr actApplicationContext.java:729)
    at org.springframework.osgi.context.support.AbstractD elegatedExecutionApplicationContext.completeRefres h(AbstractDelegatedExecutionApplicationContext.jav a:276)
    at org.springframework.osgi.extender.internal.depende ncies.startup.DependencyWaiterApplicationContextEx ecutor$CompleteRefreshTask.run(DependencyWaiterApp licationContextExecutor.java:145)
    at com.springsource.platform.kernel.dm.ContextPropaga tingTaskExecutor$2.run(ContextPropagatingTaskExecu tor.java:82)
    at java.util.concurrent.ThreadPoolExecutor$Worker.run Task(Unknown Source)
    at java.util.concurrent.ThreadPoolExecutor$Worker.run (Unknown Source)
    at java.lang.Thread.run(Unknown Source)

    [2008-07-31 13:02:49.890] platform-dm-7 <SPFF0003E> Bundle 'com.springsource.platform.deployer.hot' in Subsystem 'com.springsource.platform.deployer' failed to start.
    org.springframework.beans.factory.BeanCreationExce ption: Error creating bean with name 'hotDeployer' defined in URL [bundleentry://71/META-INF/spring/deployer-hot-context.xml]: Invocation of init method failed; nested exception is com.springsource.platform.deployer.core.FatalDeplo ymentException: Deployer recovery appears not to have completed.
    at org.springframework.beans.factory.support.Abstract AutowireCapableBeanFactory.initializeBean(Abstract AutowireCapableBeanFactory.java:1337)
    at org.springframework.beans.factory.support.Abstract AutowireCapableBeanFactory.doCreateBean(AbstractAu towireCapableBeanFactory.java:473)
    at org.springframework.beans.factory.support.Abstract AutowireCapableBeanFactory$1.run(AbstractAutowireC apableBeanFactory.java:409)
    at java.security.AccessController.doPrivileged(Native Method)
    at org.springframework.beans.factory.support.Abstract AutowireCapableBeanFactory.createBean(AbstractAuto wireCapableBeanFactory.java:380)
    at org.springframework.beans.factory.support.Abstract BeanFactory$1.getObject(AbstractBeanFactory.java:2 64)

  • #2
    error on debug S2AP start

    Can you give us a feel for how many applications you have installed, and how complex they are? My suspicion here is that deployer recovery (the process the deploys previously deployed applications upon Platform startup), is taking longer to complete than the hot deployer is prepared to wait.

    Thanks,
    Andy

    Comment


    • #3
      error on debug S2AP start

      There is 7 bundles in my application.
      I use sybase db, jasper-reporting and many specific logic.
      I took petclinic as start template but without web bundle.

      There are many bundles in repository/bundles/user that belong to petclinic and not used in my application.

      Comment


      • #4
        error on debug S2AP start

        Hi,

        The same problem is already reported here
        https://jira.springsource.com/browse/ENGINE-1399

        Comment


        • #5
          error on debug S2AP start

          @rmadala I haven't an account for jira

          @awilkinson
          Currently I removed all my bundles and tried to start AP in debug mode again.
          I got the same error.

          Comment


          • #6
            error on debug S2AP start

            Hi Roman,

            Thanks for the info. I've opened an issue on the public JIRA to track this problem: https://issuetracker.springsource.com/browse/PLATFORM-149. The issue also describes a workaround to minimise deployer recovery processing, which will, hopefully, alleviate the problem.

            Thanks,
            Andy

            Comment

            Working...
            X