Announcement Announcement Module
Collapse
No announcement yet.
SpringSource dm Server with WebFlow dependency resolving problems Page Title Module
Move Remove Collapse
X
Conversation Detail Module
Collapse
  • Filter
  • Time
  • Show
Clear All
new posts

  • SpringSource dm Server with WebFlow dependency resolving problems

    Hi,

    Today I tried to install a Spring WebFlow project onto the dm server but it told me that it has no webflow support. Ok, I installed the webflow library from eclipse toolings repository browser, but some dependencies were still missing. I installed the remaining dependant packages manually and found that some packages are not resolving well. This is an excerpt from the osgi console output:

    ...
    97 INSTALLED org.springframework.webflow_2.0.2.RELEASE
    98 ACTIVE com.springsource.org.ognl_2.7.3
    99 ACTIVE org.springframework.security_2.0.2.A
    100 INSTALLED org.springframework.security.ui.portlet_2.0.0.A
    101 ACTIVE org.springframework.web.portlet_2.5.5.A
    102 ACTIVE org.springframework.binding_2.0.2.RELEASE
    104 ACTIVE org.springframework.js_2.0.2.RELEASE
    105 INSTALLED org.springframework.faces_2.0.2.RELEASE
    106 ACTIVE org.springframework.aspects_2.5.5.A

    osgi> diag 97
    file:///D:1appspringsource-dm-server-1.0.0.RC2
    epositoryundlesusrorg.springframework.webflow-2.0.2.RELEASE.jar [97]
    Direct constraints which are unresolved:
    Missing imported package junit.framework_[3.8.2,4.0.0).
    Missing imported package org.springframework.binding.collection_[2.0.2,2.0.2].
    Missing imported package org.springframework.binding.convert_[2.0.2,2.0.2].
    Missing imported package org.springframework.binding.convert.service_[2.0.2,2.0.2].
    Missing imported package org.springframework.binding.expression_[2.0.2,2.0.2].
    Missing imported package org.springframework.binding.expression.el_[2.0.2,2.0.2].
    Missing imported package org.springframework.binding.expression.ognl_[2.0.2,2.0.2].
    Missing imported package org.springframework.binding.expression.support_[2.0.2,2.0.2].
    Missing imported package org.springframework.binding.format_[2.0.2,2.0.2].
    Missing imported package org.springframework.binding.format.registry_[2.0.2,2.0.2].
    Missing imported package org.springframework.binding.mapping_[2.0.2,2.0.2].
    Missing imported package org.springframework.binding.mapping.impl_[2.0.2,2.0.2].
    Missing imported package org.springframework.binding.message_[2.0.2,2.0.2].
    Missing imported package org.springframework.binding.method_[2.0.2,2.0.2].
    Missing imported package org.springframework.js.ajax_[2.0.2,2.0.2].
    Missing imported package org.springframework.js.ajax.tiles2_[2.0.2,2.0.2].

    osgi> packages 102
    org.springframework.binding.collection; version="2.0.2.RELEASE"<...>
    org.springframework.binding.convert; version="2.0.2.RELEASE"<...>
    org.springframework.binding.convert.converters; version="2.0.2.RELEASE"<...>
    org.springframework.binding.convert.service; version="2.0.2.RELEASE"<...>
    org.springframework.binding.expression; version="2.0.2.RELEASE"<...>
    org.springframework.binding.expression.beanwrapper ; version="2.0.2.RELEASE"<...>
    org.springframework.binding.expression.el; version="2.0.2.RELEASE"<...>
    org.springframework.binding.expression.ognl; version="2.0.2.RELEASE"<...>
    org.springframework.binding.expression.support; version="2.0.2.RELEASE"<...>
    org.springframework.binding.format; version="2.0.2.RELEASE"<...>
    org.springframework.binding.mapping; version="2.0.2.RELEASE"<...>
    org.springframework.binding.mapping.impl; version="2.0.2.RELEASE"<...>
    org.springframework.binding.mapping.results; version="2.0.2.RELEASE"<...>
    org.springframework.binding.message; version="2.0.2.RELEASE"<...>
    org.springframework.binding.method; version="2.0.2.RELEASE"<...>

    osgi> packages 104
    org.springframework.js.ajax; version="2.0.2.RELEASE"<...>
    org.springframework.js.ajax.tiles2; version="2.0.2.RELEASE"<...>
    org.springframework.js.resource; version="2.0.2.RELEASE"<...>

    I cut out some parts because of the maximum length of comments.
    So it seems the org.springframework.binding and org.springframework.js bundles are exporting the required packages but the org.springframework.webflow package isn't resolving. Am I doing something wrong?

  • #2
    SpringSource dm Server with WebFlow dependency resolving problems

    Hi,

    I think you're being slightly mis-lead by some overzealous output from diag. I suspect that there's actually only one package which the WebFlow bundle is missing:

    Missing imported package junit.framework_[3.8.2,4.0.0)

    I'd try adding the Junit bundle and seeing if that solves the problem.

    As a slight aside, the webflow bundle shouldn't actually have a dependency upon Junit and this has been fixed in 2.0.3: http://www.springsource.com/repository/app/bundle/version/detail?name=org.springframework.webflow&version=2. 0.3.RELEASE

    Regards,
    Andy

    Comment

    Working...
    X