Announcement Announcement Module
Collapse
No announcement yet.
Start of the dm-server with the Eclipse-Tooling fails Page Title Module
Move Remove Collapse
X
Conversation Detail Module
Collapse
  • Filter
  • Time
  • Show
Clear All
new posts

  • Start of the dm-server with the Eclipse-Tooling fails

    Hello,

    after I get the DM-Server running I want to try out the Tooling provided by the Eclipse Features. But the start of the server fails with this error message:

    [2008-09-16 11:58:37.625] main <SPKB0001I> Server starting.
    [2008-09-16 11:58:40.734] main <SPOF0002E> Unable to start OSGi telnet console. Port 2401 is in use.
    [2008-09-16 11:58:40.734] main <SPOF0003I> Immediate shutdown initiated.

    Ok, I think perhaps there is really a system service running on this port. But the call "netstat -ao" doesn't show anything using this port. So I change the port in config/server.config. No I getting the same message...only with the new configured port:

    [2008-09-16 11:58:37.625] main <SPKB0001I> Server starting.
    [2008-09-16 11:58:40.734] main <SPOF0002E> Unable to start OSGi telnet console. Port 2402 is in use.
    [2008-09-16 11:58:40.734] main <SPOF0003I> Immediate shutdown initiated.

    Hmm...now I tried to disable the OSGI-Console. The start needs more time but:

    [2008-09-16 12:04:50.000] main <SPKB0001I> Server starting.
    [2008-09-16 12:04:54.234] main <SPKE0000I> Boot subsystems installed.
    [2008-09-16 12:04:55.640] main <SPKE0001I> Base subsystems installed.
    [2008-09-16 12:04:57.187] server-dm-0 <SPCN0005E> Unable to start RMI Registry. Port 9875 is in use.
    [2008-09-16 12:04:57.187] server-dm-0 <SPOF0003I> Immediate shutdown initiated.
    [2008-09-16 12:04:57.203] server-dm-14 <SPPM0000I> Installing profile 'web'.

    This is very curious, i think. If I start the dm-server from the console the server remarks that port 8080 is in use. But I cannot see anything using this port. As an additional info starting a simple tomcat at port 8080 works very fine.

    Can anyone help me?

    Bye
    Thorsten

  • #2
    Start of the dm-server with the Eclipse-Tooling fails

    Thorsten,

    What OS/JVM are you running on?

    Rob

    Comment


    • #3
      Start of the dm-server with the Eclipse-Tooling fails

      Rob,

      OS: Windows XP SP2
      JVM: java version "1.6.0_07"
      Java(TM) SE Runtime Environment (build 1.6.0_07-b06)
      Java HotSpot(TM) Client VM (build 10.0-b23, mixed mode, sharing)

      Thorsten

      Comment


      • #4
        Start of the dm-server with the Eclipse-Tooling fails

        Thorsten,

        Just to clarify, is this when you start dm Server from the command line, or from within the tooling (e.g. from STS)?

        Cheers, Paul

        Comment


        • #5
          Start of the dm-server with the Eclipse-Tooling fails

          Paul,

          from within the tooling. commandline works fine...

          But remark:
          >If I start the dm-server from the console the server remarks that port 8080 is in use.
          > But I cannot see anything using this port. As an additional info starting a simple tomcat at port 8080 works very fine.


          Bye
          Thorsten

          Comment


          • #6
            Start of the dm-server with the Eclipse-Tooling fails

            Thorsten,

            We've tried reproducing your problem here and everything is working fine. I can only suggest the obvious things now, like rebooting (I'm guessing you've tried that!), updating to the latest version of the tooling, etc. Be sure to try starting from within the tooling straight after reboot to try to limit what could be getting in the way. Report back if you have any success, and if not we'll think some more!

            Cheers, Paul

            Comment


            • #7
              Start of the dm-server with the Eclipse-Tooling fails

              Updated:
              I'm having the same issue here and can't find out what is the problem. I have one installation on Windows Vista and one on Linux. This error only occures on Windows, the Linux version of Eclipse+STS+S2DM Server is working fine. Still after disabling the firewall and UAC the error remained. I even built S2DM Server from sources but it still produced the error.

              Comment


              • #8
                Start of the dm-server with the Eclipse-Tooling fails

                hmm...can anyone post the relevant code checking if the port is in use? maybe we can find out why this happens on windows machines...

                bye
                Thorsten

                Comment


                • #9
                  Start of the dm-server with the Eclipse-Tooling fails

                  Status report: the error occures in com.springsource.server.osgi.framework.equinox.Equ inoxOsgiFramework.java's startConsoleIfRequired(). I'll post if I find the exact solution.

                  Update: any time now :>

                  Comment


                  • #10
                    Start of the dm-server with the Eclipse-Tooling fails

                    thanks for your effort

                    Comment


                    • #11
                      Start of the dm-server with the Eclipse-Tooling fails

                      I think I found it. I'll create a new JIRA ticket for this issue with the patch recommendation.

                      Comment


                      • #12
                        Start of the dm-server with the Eclipse-Tooling fails

                        ok thanks...can you post the link?

                        Comment


                        • #13
                          Start of the dm-server with the Eclipse-Tooling fails

                          https://issuetracker.springsource.com/browse/PLATFORM-172

                          Comment


                          • #14
                            Start of the dm-server with the Eclipse-Tooling fails

                            Thorsten,

                            The code for checking port availability is in NetUtils:

                            http://rafb.net/p/tCZt7k86.html

                            Regards,

                            Rob

                            Comment


                            • #15
                              Start of the dm-server with the Eclipse-Tooling fails

                              Thorsten,

                              If your JIRA issues are solved, please look at the ticket I pasted before. The problem is solved.

                              Alex

                              Comment

                              Working...
                              X