Announcement Announcement Module
Collapse
No announcement yet.
Spring WS Transport conflicting export Page Title Module
Move Remove Collapse
X
Conversation Detail Module
Collapse
  • Filter
  • Time
  • Show
Clear All
new posts

  • Spring WS Transport conflicting export

    Hi, I am trying to use Spring Web Services with the Application Platform. I get the following error when trying start my application

    exports of package 'org.springframework.ws.transport.http' from sources "Import-Library 'org.springframework.spring' version '2.5.5.A'(null), Import-Library 'org.aspectj' version '1.6.1'(null), Import-Library 'org.hibernate.ejb' version '3.3.2.GA'(null), Import-Bundle 'org.springframework.ws.transport' version '1.5.4.A', Import-Bundle 'org.springframework.ws' version '1.5.4.A'".

    I have looked at the manifests and both 'org.springframework.ws.transport" and "'org.springframework.ws" export the package "org.springframework.ws.transport.http". As a work around I have made org.springframework.ws.transport a fragment-host of org.springframework.ws but I'm not sure if this is the best solution?

  • #2
    Spring WS Transport conflicting export

    Hi,

    This is a known problem with the Spring Web Services bundles: https://issuetracker.springsource.com/browse/BRITS-136. Your current approach of using a fragment is the recommended workaround until this has been fixed 'officially'.

    Regards,
    Andy

    Comment


    • #3
      Spring WS Transport conflicting export

      Thanks Andy, I'll keep an eye on the issue.

      Comment

      Working...
      X