Announcement Announcement Module
Collapse
No announcement yet.
FatalParseException for Export-Package Page Title Module
Move Remove Collapse
X
Conversation Detail Module
Collapse
  • Filter
  • Time
  • Show
Clear All
new posts

  • FatalParseException for Export-Package

    While unusual, and probably not a good idea, the following manifest entry is fine within Eclipse, but not with S2AP (it gives a FatalParseException).
    Export-Package: .,
    another.package

    Surely S2AP should be able to handle the same Manifest entries as Eclipse happily does.

  • #2
    FatalParseException for Export-Package

    Eclipse is actually in error there - there is no package '.'. OSGi has no way of representing the default package, and . is certainly not valid.

    You can see this described in the BNF in section 1.3.2 of the OSGi R4 spec.

    Hope this helps.

    Regards, Rob

    Comment

    Working...
    X