Announcement Announcement Module
Collapse
No announcement yet.
ImportMergeException using Spring Web Services 1.5.2.A Page Title Module
Move Remove Collapse
X
Conversation Detail Module
Collapse
  • Filter
  • Time
  • Show
Clear All
new posts

  • ImportMergeException using Spring Web Services 1.5.2.A

    I'm getting an ImportMergeException when trying to import bundle Spring Web Services modules.

    I'm pretty sure it's down to a split package, but I'm not sure what to do to fix it (or whether I should just be JIRA-ing either Spring Web Services or the Enterprise Bundle Repository).

    The relevant snippet from my bundle's manifest is:

    Import-Library: org.hibernate.ejb,
    org.springframework.spring
    Import-Bundle: com.springsource.org.apache.commons.dbcp,
    org.springframework.ws,
    org.springframework.ws.transport,
    org.springframework.oxm,
    org.springframework.ws.java5,
    org.springframework.oxm.java5

    I have to pull in org.springframework ws, ws.transport and ws.java5 as the functionality I'm after (annotated endpoints) is split across all three modules (same with the oxm module).

    I think the error comes up because ws and ws.transport both export the same package (there are transport related packages in the ws core module).

    Any clues on how I can work around this?

  • #2
    ImportMergeException using Spring Web Services 1.5.2.A

    Hi Mark,

    There does appear to be an issue regarding split packages: both the org.springframework.ws bundle and the org.springframework.transport bundle export the org.springframework.transport.http package. The ImportMergeException you encountered was therefore likely a result of this.

    Ideally, the bundles should not export the same package. If that's not possible, however, you could create a work-around by configuring the org.springframework.transport bundle to be a fragment of the org.springframework.ws bundle.

    I've created a JIRA issue to track this:

    https://issuetracker.springsource.com/browse/BRITS-136

    Regards,

    Sam

    Comment


    • #3
      ImportMergeException using Spring Web Services 1.5.2.A

      Hi Sam,

      Thanks for the confirmation and raising the JIRA issue.

      Cheers,
      Mark

      Comment

      Working...
      X