Announcement Announcement Module
Collapse
No announcement yet.
ImportMergeException Page Title Module
Move Remove Collapse
X
Conversation Detail Module
Collapse
  • Filter
  • Time
  • Show
Clear All
new posts

  • ImportMergeException

    Hi,
    I'm playing with the Application Platform and the Eclipse tools for it, and I came to an issue I don't understand and haven't found any hint of it anywhere...

    I have migrated a wicket webapp to a war package deployed to SpringSource AP and add OSGi headers to the manifests of our libraries, so that the libs are now imported to the war. I got it working once, but after some changes (and I really don't know what the changes exactly were, but mainly refactoring of the libs) it has stopped working. The deployment to the server says:

    com.springsource.platform.osgi.framework.ImportMer geException: conflicting values 'com.tietoenator.di.ria.wicket.wicket_jQuery', 'com.tietoenator.di.ria.wicket.wicket13_components ' of attribute 'bundle-symbolic-name'

    (Bundle-SymbolicName is really unique for all the bundles...)

    As I said before, I haven't found any clue what could that mean. Do you have any ideas?

    I attach the manifest of the war if it may be of a help.

    Best regards
    Jaroslav

    Manifest-Version: 1.0
    Bundle-ManifestVersion: 2
    Bundle-SymbolicName: wicket_test
    Bundle-Version: 1.0
    Bundle-Name: Wicket Test
    Import-Bundle: org.springframework.osgi.core,
    org.springframework.osgi.io,
    org.springframework.osgi.extender,
    org.apache.wicket.wicket,
    org.apache.wicket.wicket-extensions,
    org.apache.wicket.wicket-ioc,
    org.apache.wicket.wicket-spring,
    org.apache.wicket.wicket-spring-annot,
    com.springsource.net.sf.cglib,
    com.tietoenator.di.ria.wicket.wicket13_components; version:="1.1.0",
    com.tietoenator.di.ria.wicket.wicket13_spring;vers ion:="1.1.0",
    com.tietoenator.di.ria.wicket.wicket_jQuery;versio n:="1.1.0",
    com.tietoenator.di.compost.compost_framework,
    com.tietoenator.dhs.domain
    Import-Library: org.springframework.spring;version:="2.5.5"

  • #2
    ImportMergeException

    Hi Jaroslav,

    It appears to me that the com.tietoenator.di.ria.wicket.wicket_jQuery and com.tietoenator.di.ria.wicket.wicket13_components bundles both export the same package; however, based on the information you've provided, I cannot determine which package that is.

    Did you see a more specific error message in the console or logging.log file?

    Regards,

    Sam

    Comment


    • #3
      ImportMergeException

      Hi,
      you're right. I've missed that. However, it could have said it in a more understandable way (something like 'conflicting exported packages'...).
      Thanks for the hint.
      I am still deep into classloader problems (new ones)...

      Jaroslav

      Comment

      Working...
      X