Announcement Announcement Module
Collapse
No announcement yet.
S2AP Tool installation problen Page Title Module
Move Remove Collapse
X
Conversation Detail Module
Collapse
  • Filter
  • Time
  • Show
Clear All
new posts

  • S2AP Tool installation problen

    Hello, all
    I tried to install S2AP tool as described in programmer's guide and got following error in Eclipse update tool :
    Requested operation cannot be performed because it would invalidate the current configuration. See details for more information.
    SpringSource Tool Suite AP Tools (1.0.0.v200807252158) requires plug-in "org.springframework.ide.eclipse.core (2.1.0)", or later version.

    Could anyone help me?

    Thanks in advance.

  • #2
    S2AP Tool installation problen

    Yep : you have to install spring IDE to be able able to install STS.
    Here is the update site for Spring IDE:
    * http://springide.org/updatesite
    -->this is the stable release

    * http://springide.org/updatesite-nightly
    -->this is the developement release : use it at your own risks


    Cheers,
    Jawher

    Comment


    • #3
      S2AP Tool installation problen

      Hi, Jawher.

      Thank you for your answer. i've installed Spring IDE v. 2.0.6, but current STS Tool requires version 2.1

      i tried http://springide.org/updatesite-nightly and STS Tool is started to install.

      Is it right, that current version of Tool update points to inexistent location?

      Cheers,
      Gennady

      Comment


      • #4
        S2AP Tool installation problen

        Not sure I'm understanting your last message.

        Anyway, this is the STS nightly update-site :
        http://static.springsource.com/projects/sts-ap/nightly/

        The last version is v1.0.0.20080729, i.e. today. and I've sucessfully installed it this morning with Spring IDE 2.1 snapshot.

        Cheers,
        Jawher.

        Comment


        • #5
          S2AP Tool installation problen

          I think what Gennady means is that the current "live" Tooling of S2AP requires Spring IDE 2.1.0 which is IMHO not publicly available yet, is it?
          Anyway, Gennady: Installing Spring IDE 2.1.0 from http://springide.org/updatesite-nightly should work fine (at least did for me).

          Regards
          Kay

          Comment


          • #6
            S2AP Tool installation problen

            Kay, you're absolutely right .
            Thanks once more, i've already installed it.

            Gennady.

            Comment

            Working...
            X