Announcement Announcement Module
Collapse
No announcement yet.
Unable to install latest STS nightly (20080721) Page Title Module
Move Remove Collapse
X
Conversation Detail Module
Collapse
  • Filter
  • Time
  • Show
Clear All
new posts

  • Unable to install latest STS nightly (20080721)

    Hello,
    I can't manage to install the latest STS nightly (20080721)
    (I've first tried to update, then uninstalled STS (and Spring ID) and tried to reinstall it, tried with Spring ID nightly, etc.

    Invariably, P2 fails with this message:

    Cannot complete the request. See the details.
    Unsatisfied dependency: [com.springsource.platform.ide.feature.feature.grou p 1.0.0.v200807210800] requiredCapability: org.eclipse.equinox.p2.iu/org.springframework.ide.eclipse.ui/2.2.0
    Cannot find a solution where both Match[requiredCapability: org.eclipse.equinox.p2.iu/org.springframework.ide.eclipse.ui/[2.1.0.v200807192031,2.1.0.v200807192031]] and Match[requiredCapability: org.eclipse.equinox.p2.iu/org.springframework.ide.eclipse.ui/2.2.0] can be satisfied.
    Cannot find a solution where both Match[requiredCapability: org.eclipse.equinox.p2.iu/org.springframework.ide.eclipse.ui/[2.1.0.v200807192031,2.1.0.v200807192031]] and Match[requiredCapability: org.eclipse.equinox.p2.iu/org.springframework.ide.eclipse.ui/2.2.0] can be satisfied.
    Cannot find a solution where both Match[requiredCapability: org.eclipse.equinox.p2.iu/org.springframework.ide.eclipse.ui/[2.1.0.v200807192031,2.1.0.v200807192031]] and Match[requiredCapability: org.eclipse.equinox.p2.iu/org.springframework.ide.eclipse.ui/2.2.0] can be satisfied.
    Cannot find a solution where both Match[requiredCapability: org.eclipse.equinox.p2.iu/org.springframework.ide.eclipse.ui/[2.1.0.v200807192031,2.1.0.v200807192031]] and Match[requiredCapability: org.eclipse.equinox.p2.iu/org.springframework.ide.eclipse.ui/2.2.0] can be satisfied.
    Cannot find a solution where both Match[requiredCapability: org.eclipse.equinox.p2.iu/org.springframework.ide.eclipse.ui/[2.1.0.v200807192031,2.1.0.v200807192031]] and Match[requiredCapability: org.eclipse.equinox.p2.iu/org.springframework.ide.eclipse.ui/2.2.0] can be satisfied.
    Cannot find a solution where both Match[requiredCapability: org.eclipse.equinox.p2.iu/org.springframework.ide.eclipse.ui/[2.1.0.v200807192031,2.1.0.v200807192031]] and Match[requiredCapability: org.eclipse.equinox.p2.iu/org.springframework.ide.eclipse.ui/2.2.0] can be satisfied.
    Unsatisfied dependency: [com.springsource.platform.ide.feature.feature.grou p 1.0.0.v200807210800] requiredCapability: org.eclipse.equinox.p2.iu/org.springframework.ide.eclipse.ui/2.2.0

  • #2
    Unable to install latest STS nightly (20080721)

    I fixed a typo in the feature meta data that P2 uses. This will be available with the next nightly build.

    Christian

    Comment


    • #3
      Unable to install latest STS nightly (20080721)

      It works now (20080722).

      Thanks.

      Comment


      • #4
        Unable to install latest STS nightly (20080721)

        I'm sorry, it still doesn't work for me. This time, it's different:

        Cannot complete the request. See the details.
        Cannot find a solution satisfying the following requirements Match[requiredCapability: org.eclipse.equinox.p2.iu/org.objectweb.asm/[2.2.3,2.2.3]].

        Am I missing something obvious?
        Regards
        Kay

        Comment


        • #5
          Unable to install latest STS nightly (20080721)

          Hi,
          Personnaly, I've managed to install the 20080722 nightly after desinstalling STS and Spring IDE and starting Eclipse with the "-clean" option.

          Comment


          • #6
            Unable to install latest STS nightly (20080721)

            I did uninstall STS and restart with -clean, but to no avail. I'm hesitating to uninstall Spring IDE (as that would probably mean to install a nightly version as well - and this part I also need for productive work on my machine ;-) )
            I hope Christian can give me a hint...?

            Regards
            Kay

            Comment


            • #7
              Unable to install latest STS nightly (20080721)

              Kay,

              can you please paste the entire resolution problem report from the P2 update manager UI into this thread. Maybe that helps me understanding your problem.

              Christian

              Comment


              • #8
                Unable to install latest STS nightly (20080721)

                Thanks Christian

                Actually the above message was all I got in the update manager detail problem description. But if nobody else has the problem, then I probably shot my eclipse installation on my own - will try to fix myself, thanks anyway ;-)

                Regards
                Kay

                Comment

                Working...
                X