Announcement Announcement Module
Collapse
No announcement yet.
clean S2AP server timeout in Eclipse Page Title Module
Move Remove Collapse
X
Conversation Detail Module
Collapse
  • Filter
  • Time
  • Show
Clear All
new posts

  • clean S2AP server timeout in Eclipse

    new install Spring IDE (2.0.6) and AP tool (1.0) in Europa.
    when i try to start the server, AP tool DID stat the server, but after a while, eclipse report:
    -----------------------------------------------------------------------------eclipse error log
    !ENTRY org.eclipse.wst.server.core 4 0 2008-07-17 18:42:54.328
    !MESSAGE Timeout waiting for SpringSource AP v1.0 Server at localhost to start. Server did not start after 300s.

    eclipse.buildId=M20080221-1800
    java.version=1.6.0_06
    java.vendor=Sun Microsystems Inc.
    BootLoader constants: OS=win32, ARCH=x86, WS=win32, NL=zh_CN
    Command-line arguments: -os win32 -ws win32 -arch x86

    --------------------------------------------------------------server log
    [2008-07-17 18:37:58.453] main <SPKB0001I> Platform starting.
    [2008-07-17 18:38:02.921] main <SPOF0001I> OSGi telnet console available on port 2401.
    [2008-07-17 18:38:06.125] main <SPKE0000I> Boot subsystems installed.
    [2008-07-17 18:38:07.968] main <SPKE0001I> Base subsystems installed.
    [2008-07-17 18:38:09.843] platform-dm-1 <SPPM0000I> Installing profile 'web'.
    [2008-07-17 18:38:11.140] platform-dm-1 <SPPM0001I> Installed profile 'web'.
    [2008-07-17 18:38:12.562] platform-dm-11 <SPSC0001I> Creating HTTP/1.1 connector with scheme http on port 8080.
    [2008-07-17 18:38:13.187] service-monitor-thread-1 <SPCC0001W> Mandatory reference '&servletContainer' in bundle 'com.springsource.platform.web.core' version '1.0.0.beta9' waiting for service with filter '(objectClass=com.springsource.platform.servlet.co re.ServletContainer)'.
    [2008-07-17 18:38:14.578] platform-dm-11 <SPSC0001I> Creating HTTP/1.1 connector with scheme https on port 8443.
    [2008-07-17 18:38:16.578] platform-dm-11 <SPSC0001I> Creating AJP/1.3 connector with scheme http on port 8009.
    [2008-07-17 18:38:16.609] platform-dm-11 <SPSC0000I> Starting ServletContainer.
    [2008-07-17 18:38:17.234] platform-dm-11 <SPCC0003I> Reference '&servletContainer' in bundle 'com.springsource.platform.web.core' version '1.0.0.beta9' was satisfied by service with filter '(objectClass=com.springsource.platform.servlet.co re.ServletContainer)'.
    [2008-07-17 18:38:17.296] platform-dm-9 <SPPM0002I> Platform open for business with profile 'web'.
    [2008-07-17 18:38:22.203] Deployer Recovery <SPSC1000I> Creating web application '/admin'.
    [2008-07-17 18:38:23.015] async-delivery-thread-1 <SPSC1001I> Starting web application '/admin'.
    [2008-07-17 18:38:24.281] Deployer Recovery <SPDE0010I> Deployment of 'platform.admin.web-1.0.0.beta9.jar' version '0' completed.
    [2008-07-17 18:38:24.859] Deployer Recovery <SPSC1000I> Creating web application '/'.
    [2008-07-17 18:38:24.906] async-delivery-thread-1 <SPSC1001I> Starting web application '/'.
    [2008-07-17 18:38:25.296] Deployer Recovery <SPDE0010I> Deployment of 'platform.admin.splash-1.0.0.beta9.war' version '0' completed.
    [2008-07-17 18:38:25.312] fs-watcher <SPDE0048I> Processing 'INITIAL' event for file 'platform.admin.web-1.0.0.beta9.jar'.
    [2008-07-17 18:38:25.312] fs-watcher <SPDE0031I> File 'platform.admin.web-1.0.0.beta9.jar' already deployed.
    [2008-07-17 18:38:25.312] fs-watcher <SPDE0048I> Processing 'INITIAL' event for file 'platform.admin.splash-1.0.0.beta9.war'.
    [2008-07-17 18:38:25.328] fs-watcher <SPDE0031I> File 'platform.admin.splash-1.0.0.beta9.war' already deployed.
    [2008-07-17 18:42:55.343] eduled-executor-thread-1 <SPOF0003I> Immediate shutdown initiated.

  • #2
    clean S2AP server timeout in Eclipse

    This is probably the same as http://www.springsource.com/beta/applicationplatform/comments.php?DiscussionID=215
    Try updating your tooling to the latest nightly build available at http://static.springsource.com/projects/sts-ap/nightly/

    Regards
    Kay

    Comment


    • #3
      clean S2AP server timeout in Eclipse

      i updated ap tool with v200807090800. the problem has been solved.

      thanks key.
      wangqi

      Comment

      Working...
      X