Announcement Announcement Module
Collapse
No announcement yet.
Issues integrating Spring 3.0 MVC with Tiles 2.1.3 on Spring DM 2 Page Title Module
Move Remove Collapse
X
Conversation Detail Module
Collapse
  • Filter
  • Time
  • Show
Clear All
new posts

  • Issues integrating Spring 3.0 MVC with Tiles 2.1.3 on Spring DM 2

    I am facing the following issues with Spring 3.0 MVC, Apache Tiles 2.1.3 on Spring DM 2 -

    1. Got the following Exception -

    Caused by: java.lang.NoClassDefFoundError: org/springframework/core/io/support/ResourcePatternResolver

    I removed version range for the following packages in the com.springsource.org.apache.tiles.servlet-2.1.3.jar

    org.springframework.core.io,
    org.springframework.core.io.support,
    org.springframework.web.context.support

    After these changes my web bundle was successfully deployed. So, where can I get the compatible Tile bundles for Spring 3?

    2. On runtime, it was not able to resolve tiles-jsp.tld. So, I have to copy tiles-jsp.tld under WEB-INF. Why my web bundle not able to see the tiles-jsp.tld from imported tile bundle? While the same work fine for other tag libs like Spring, JSTL etc.

    Regards,
    Pranav

  • #2
    You'll have to get an updated version of tiles and, if it doesn't have suitable manifests, run bundlor to generate manifests.

    As the the resource loading, it depends on the directory structure where the resource is stored matching the package imports/exports.

    Comment


    • #3
      Tiles 2.1.3 is the latest version avaliable from the EBR and has been confirmed as working with Spring 3 (There are no version ranges on the tiles servlet from apache so it appears to be an oversite on our part when it got added to the EBR).

      It would be worth trying the 2.1.4 tiles jars from apache, their manifests look decent so it my well work in OSGi. In the meantime I have noted this information in an existing JIRA for the problem. https://issuetracker.springsource.com/browse/EBR-502
      Last edited by Glyn Normington; Jan 25th, 2010, 02:28 AM.

      Comment


      • #4
        Your second point is interesting, I'm just working on a recreation of it now. It was a known issue for a while and a general fix was implemented.I don't know what could be special about the tiles jps bundle. I will continue discussion about it in this thread as mroe people have this problem and are looking at it there, including yourself. http://forum.springsource.org/showthread.php?t=83351

        Comment

        Working...
        X