Announcement Announcement Module
Collapse
No announcement yet.
using struts2 tiles support in web bundle in dm 2 Page Title Module
Move Remove Collapse
X
Conversation Detail Module
Collapse
  • Filter
  • Time
  • Show
Clear All
new posts

  • using struts2 tiles support in web bundle in dm 2

    I am trying to run my web-app under dm 2 .0.0 RELEASE ,
    I am using struts 2 and tiles but i get

    Code:
    org.apache.jasper.JasperException: The absolute uri: http://tiles.apache.org/tags-tiles cannot be resolved in either web.xml or the jar files deployed with this application
    Then i included tiles-jsp.tld under WEB-INF and it worked .

    do i need to include all such static content into my web-app bundle .

  • #2
    Hi Vishalj,

    How are you importing the bundle with the tiles tlds in it. If you are using Import-Package to get the packages you need could you explicitly do an Import-Bundle: for it and double check it actually has the tlds in it. That should work, if not I'll investigate further.

    Thanks, Chris.

    Comment


    • #3
      Hi Chris,

      Even I am facing the same issue. I downloaded com.springsource.org.apache.tiles.jsp-2.1.3.jar from Spring Bundle Repository. It has tld.

      I am using Import-Bundle: com.springsource.org.apache.tiles.jsp in MANIFEST file.

      Regards,
      Pranav

      Comment


      • #4
        I had imported the bundle in my Manifest and checked the bundle it had the tld under META-INF/tld


        This is the location i got the bundle from repository

        Comment


        • #5
          This is very odd, this was specifically fixed and dose work for many jar files containing tlds. There are 2 ways to get hold of them.

          I recommend that you try and get them directly from the tiles jsp bundle. Could you confirm you are referencing them in the right place, tiles dose not place them directly under the META-INF dir. They are in '/META-INF/tld/tiles-jsp.tld'. This is quicker than getting them from the internet.

          Please let me know if that is not working. Also, if you still want to get it from the internet could you paste in the line that references it. Is it simply in the form "<%@ taglib uri=..."

          Chris.

          Comment

          Working...
          X